Mirth Community

Mirth Community (http://www.mirthcorp.com/community/forums/index.php)
-   Development (http://www.mirthcorp.com/community/forums/forumdisplay.php?f=8)
-   -   error occurred while creating a new channel (http://www.mirthcorp.com/community/forums/showthread.php?t=4773)

sangireddi 11-24-2010 11:28 PM

error occurred while creating a new channel
 
Hi All,
I build and run the mirth from the source.after i run the application i am getting client UI successfully but while i tried to create a new channel it is telling that you must have atleast one source connector and one destination connector installed .


if we click on channels in the left pane i am getting error like below.


com.webreach.mirth.client.core.ClientException: method failed: HTTP/1.1 500 com.ibatis.common.jdbc.exception.NestedSQLExceptio n:
--- The error occurred in postgres/postgres-channel.xml.
--- The error occurred while applying a result map.
--- Check the Channel.get-channel-result.
--- Check the result mapping for the 'sourceConnector' property.
--- Cause: com.thoughtworks.xstream.mapper.CannotResolveClass Exception: com.mirth.connect.model.Connector : com.mirth.connect.model.Connector
Caused by: com.thoughtworks.xstream.mapper.CannotResolveClass Exception: com.mirth.connect.model.Connector : com.mirth.connect.model.Connector
com.webreach.mirth.client.core.ServerConnection.ex ecutePostMethod(ServerConnection.java:123)
com.webreach.mirth.client.core.Client.getChannel(C lient.java:192)
com.webreach.mirth.client.ui.Frame.retrieveChannel s(Frame.java:2218)
com.webreach.mirth.client.ui.Frame$16.doInBackgrou nd(Frame.java:2170)
com.webreach.mirth.client.ui.Frame$16.doInBackgrou nd(Frame.java:2174)
org.jdesktop.swingworker.SwingWorker$1.call(SwingW orker.java:276)
java.util.concurrent.FutureTask$Sync.innerRun(Unkn own Source)
java.util.concurrent.FutureTask.run(Unknown Source)
org.jdesktop.swingworker.SwingWorker.run(SwingWork er.java:315)
java.util.concurrent.ThreadPoolExecutor$Worker.run Task(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run (Unknown Source)
java.lang.Thread.run(Unknown Source)


please suggest me the how to resolve this problem.can we modify mirth source to edit some source for production purpose.

jacobb 11-29-2010 02:42 PM

Did you add the build directory to your classpath? I'm assuming you're trying to run it from your IDE?

sangireddi 11-30-2010 06:35 PM

Thank you for your reply ...
Yes,I am running mirth 1.8.2 from eclipse IDE. i added mirth/server/conf,mirth/server/lib/,mirth/server/build to the classpath.but still i am getting same(above) problem.please suggest me if i miss something.
Thanks in advance.


All times are GMT -8. The time now is 01:02 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation