web stats
Mirth Community - View Single Post - custom web service issue on 3.0.3
View Single Post
  #5  
Old 03-10-2015, 07:23 AM
narupley's Avatar
narupley narupley is online now
Mirth Employee
 
Join Date: Oct 2010
Posts: 7,117
narupley is on a distinguished road
Default

Quote:
Originally Posted by mdehoog View Post
Got an error on the jar:

Code:
ERROR (com.mirth.connect.connectors.ws.WebServiceReceiver:132): Custom web service class initialization failed
java.lang.ClassNotFoundException: com.mirth.connect.connectors.ws.CustomAcceptMessage
That indicates you're not including your custom JAR correctly. Assuming you're working with the latest version (3.2), add your JAR as a resource in the Settings -> Resources view. Then on the channel Summary tab, hit Set Libraries, and check your resource for your source connector. Then redeploy the channel and your custom library should be used.

Also FYI, to dispatch a message to a channel from a custom web service, just call one of the processData methods on the WebServiceReceiver object. You can use the one that takes a RawMessage object, then pass in the destination metadata IDs to dispatch only to particular destinations.
__________________
Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

Nicholas Rupley
Work: 949-237-6069
Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


- How do I foo?
- You just bar.
Reply With Quote