web stats
Web Service Sender Edit Respones problem - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 10-13-2015, 08:55 AM
FryderykII FryderykII is offline
What's HL7?
 
Join Date: Sep 2015
Posts: 3
FryderykII is on a distinguished road
Question Web Service Sender Edit Respones problem

In my channel I have Web Service Sender, which gives me respone like this one:

<soap:Envelope xmlns:env="http://www.w3.org/2003/05/soap-envelope" xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<env:Header/>
<soap:Body>
<GetPatientResponse xmlns="http://tempuri.org/">
<GetPatientResult>
<Name>John</Name>
<Surname>Smith</Surname>
<Address>
<City>London</City>
</Address>
</GetPatientResult>
</GetPatientResponse>
</soap:Body>
</soap:Envelope>

In my Message Templates in Edit Response i also have this message. The problem is, when i try to get values from msg, they are empty, for example :

var name = msg['soap:Body']['GetPatientResponse']['GetPatientResult']['Name'].toString();

and there is no value in this variable.

If anyone has some idea why this is not working?
Reply With Quote
Reply

Tags
javascript, msg, response, soap, templates

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation