web stats
Intermittently can't launch Administrator with 'Error Downloading/Verifying Codebase' - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 12-31-2018, 10:07 AM
jridderhoff jridderhoff is offline
OBX.1 Kenobi
 
Join Date: Jan 2015
Posts: 35
jridderhoff is on a distinguished road
Default Intermittently can't launch Administrator with 'Error Downloading/Verifying Codebase'

We've been encountering a frustratingly sneaky problem recently when attempting to connect to our instances of Mirth Connect 3.6.1. Sometimes it works fine, but seemingly at random for extended periods of time, any attempt to connect the launcher (either via the NextGen Connect Administrator Launcher or via the Mirth Connect Administrator web page) fails.

When attempted via the web page, it just times out; when attempting via the Administrator Launcher (using the built-in JVM), we get the following error:

Code:
Error Downloading/Verifying Codebase
The markup in the document preceding the root element must be well-formed.
org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 3; The markup in the document preceding the root element must be well-formed.
	at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
	at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
	at com.mirth.connect.client.launcher.f.a(SourceFile:664)
	at com.mirth.connect.client.launcher.f.a(SourceFile:167)
	at com.mirth.connect.client.launcher.MirthClientLauncher.run(SourceFile:1122)
	at java.lang.Thread.run(Unknown Source)
During this time, we can still get to the Administrator Launcher web page in a browser (//<host>:<http.port>/), but attempting to actually click the "Launch Mirth Connect Administrator" button just times out.

There are no errors logged in mirth.log, and we know the port is open because we can still telnet to the host using the port configured as http.port in mirth.properties. Running ps -ef | grep mcservice still shows that mcservice is running. There are other applications running on the same server, and there is ample available RAM and CPU%.

Even more oddly, the problem seems to self-resolve after an extended period of time. Coming back and attempting again some hours later, it's as if there was never a problem (nothing logged, everything responding as expected).

We're running:
CentOS Linux release 7.6.1810 (Core)
Oracle jdk1.8.0_191-amd64
Mirth Connect 3.6.1
NextGen Connect Administrator Launcher using Default Java Home (1.8.0_191-b12)

Any thoughts or further troubleshooting suggestions? At the moment, if we urgently need to access the Administrator console during one of these recalcitrant periods, our only option is to kill the mcservice process and restart the service again (usually in this phase, running mcservice stop doesn't actually the process, despite feedback saying that the daemon has been stopped).

Thanks!
Reply With Quote
  #2  
Old 02-20-2019, 10:40 AM
jridderhoff jridderhoff is offline
OBX.1 Kenobi
 
Join Date: Jan 2015
Posts: 35
jridderhoff is on a distinguished road
Exclamation

Hate to bump the thread, but we're still running into this periodically in our production environment, and it's quite a problem when it does (as we often have to do emergency maintenance to recover from it in a timely fashion).

Anybody even have any troubleshooting steps we can try, beyond what we've already looked at above? Not sure if this is an issue with Java GC causing the unresponsiveness, or a bug with the Mirth app itself, or if it's something resource-related on the server overall, but something keeps causing the app to go into seclusion and not let us in. Not a comfortable place to be in.

Thanks.
Reply With Quote
  #3  
Old 03-15-2019, 05:48 AM
interoneca interoneca is offline
What's HL7?
 
Join Date: Dec 2018
Posts: 5
interoneca is on a distinguished road
Default

I just upgraded Mirth Connect from 3.5 to 3.7 and I am continuously getting the same error when trying to launch a connection from Administrator Launcher. Before the upgrade it was working just fine.

Does anyone have a solution for this?

Error reading Java home directory: ../../jre
java.lang.Exception: Error reading Java home directory: ../../jre
at com.mirth.connect.client.launcher.L.a(SourceFile:1 61)
at com.mirth.connect.client.launcher.MirthClientLaunc her.run(SourceFile:2538)
at java.lang.Thread.run(Unknown Source)

Thanks
Reply With Quote
  #4  
Old 05-21-2019, 10:15 PM
DAO DAO is offline
What's HL7?
 
Join Date: May 2019
Posts: 1
DAO is on a distinguished road
Default

Does anyone have know how to resolve this issue..? Running into the same problem with Mirth 3.6.1. We recently moved to an all docker environment, problems started after migration
Reply With Quote
Reply

Tags
error downloading, launcher, webstart.jnlp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation