web stats
Sending data to Mirth Web Service Listener - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 07-15-2014, 06:27 AM
vivek.feelfree vivek.feelfree is offline
What's HL7?
 
Join Date: Jun 2013
Posts: 4
vivek.feelfree is on a distinguished road
Unhappy Sending data to Mirth Web Service Listener

Hi,

We have created a Mirth channel with Web Service Listener as source. We have a standardised C# application that generates the SOAP message and send the data to any web service. It is sending data to all kind of web services except the service available in the Mirth Web Service Listener.

Generated SOAP message :

Code:
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:level1="http://ws.connectors.connect.mirth.com/">
  <soap:Body>
    <level1:acceptMessage>
      <level1:arg0>test Data</level1:arg0>
    </level1:acceptMessage>
  </soap:Body>
</soap:Envelope>
But if we are removing the namespace information (level1) for the argument alone, then it is successfully sending the data.

For that SOAP message :

Code:
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:level1="http://ws.connectors.connect.mirth.com/">
  <soap:Body>
    <level1:acceptMessage>
      <arg0>test Data</arg0>
    </level1:acceptMessage>
  </soap:Body>
</soap:Envelope>
What might be the issue here? Could anyone please help?
Reply With Quote
Reply

Tags
listener, soap, web service

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation