web stats
Not receiving messages - Mirth Community

Go Back   Mirth Community > Mirth Connect > Development

Reply
 
Thread Tools Display Modes
  #1  
Old 09-05-2006, 07:34 AM
nshaik nshaik is offline
Mirth Guru
 
Join Date: Sep 2006
Posts: 302
nshaik
Default Not receiving messages

Hello,

I'm from Windows background and trying to setup Mirth HL7. Please pardon me if I have missed something that is too basic.

I was able to setup and deploy an LLP channel. The "Mirth Administrator" status shows "Started".

I'm trying to send HL7 messages to this channel from GE Centricity Practice Manager 2004. I updated a test patient's phone number and hit OK on the Centricity client application. The HL7 log indicates that the message has been sent successfully (shown below).

-------------
************************************************** *******
09/05/2006 10:48:08 +Send #=0, id=534, data=560, type=HL7 2.3^ADT^A08

09/05/2006 10:48:09 ++Send done No Ack Requested, status=MIK_OKNOACK, msg=E4F0F343-81EA-4e61-AC74-1DEF7981A98B, dest=MirthHL7

09/05/2006 10:48:09 +Send #=0, id=535, data=560, type=HL7 2.3^ADT^A31

09/05/2006 10:48:09 ++Send done No Ack Requested, status=MIK_OKNOACK, msg=B79BE22B-9E9E-4d54-A1BB-F0A17F937B01, dest=MirthHL7

09/05/2006 10:56:41 +Send #=0, id=536, data=562, type=HL7 2.3^ADT^A08

09/05/2006 10:56:41 ++Send done No Ack Requested, status=MIK_OKNOACK, msg=0B93EEE8-C4BF-4a38-9394-4F9C3F4F8F5D, dest=MirthHL7

09/05/2006 10:56:41 +Send #=0, id=537, data=562, type=HL7 2.3^ADT^A31

09/05/2006 10:56:42 ++Send done No Ack Requested, status=MIK_OKNOACK, msg=6FACE1F0-91F1-4c52-9D19-41E39C2A4C7D, dest=MirthHL7
------------

But Mirth HL7 is not receiving the message. Right-click/Refresh on "Mirth Administrator" status shows 0 (zero) under "Received".

Any help in getting this problem resolved is greatly appreciated.

Thanks in advance!
-NS
Reply With Quote
  #2  
Old 09-05-2006, 10:16 AM
chrisl chrisl is offline
Mirth Employee
 
Join Date: Aug 2006
Posts: 967
chrisl is an unknown quantity at this point
Default Re: Not receiving messages

Are both systems on the local network?
__________________
Chris Lang
Reply With Quote
  #3  
Old 09-05-2006, 10:29 AM
nshaik nshaik is offline
Mirth Guru
 
Join Date: Sep 2006
Posts: 302
nshaik
Default Re: Not receiving messages

Yes. Both system are on the local network (same domain).

-NS
Reply With Quote
  #4  
Old 09-05-2006, 11:06 AM
chrisl chrisl is offline
Mirth Employee
 
Join Date: Aug 2006
Posts: 967
chrisl is an unknown quantity at this point
Default Re: Not receiving messages

Is Mirth running on a Windows system? Is there any firewall (software or hardware) on the Mirth system? For the LLP Listener, are you using the default port and settings? Make sure the LLP listener is set to use HEX encoding for the LLP characters.

Check the \logs folder in the Mirth directory and look at mirth.log. Do you see any errors or warnings there?
__________________
Chris Lang
Reply With Quote
  #5  
Old 09-05-2006, 12:26 PM
nshaik nshaik is offline
Mirth Guru
 
Join Date: Sep 2006
Posts: 302
nshaik
Default Re: Not receiving messages

1. Environment:

Mirth System: Windows 2000 Server SP4, Mirth v1.1. No Firewall.

*************
2. Log

INFO [Thread-0] com.webreach.mirth.server.Mirth: starting mirth server...

*************
3. Exported channel setting is as follows:

Code:
<com.webreach.mirth.model.Channel>
<id>1</id>
<name>MirthHL7</name>
<description>HL7 Messages from DEVSERVER - Centricity Practice Manager 2004</description>
<enabled>true</enabled>
<version>1.1.0</version>
<revision>0</revision>
<direction>INBOUND</direction>
<mode>ROUTER</mode>
<sourceConnector>
<name>sourceConnector</name>
<properties>
<property name="tcpProtocolClassName" value="org.mule.providers.tcp.protocols.LlpProtocol"/>
<property name="messageEnd" value="0x1C"/>
<property name="sendACK" value="1"/>
<property name="keepSendSocketOpen" value="1"/>
<property name="bufferSize" value="65536"/>
<property name="port" value="6661"/>
<property name="messageStart" value="0x0B"/>
<property name="charEncoding" value="hex"/>
<property name="DataType" value="LLP Listener"/>
<property name="recordSeparator" value="0x0D"/>
<property name="receiveTimeout" value="5000"/>
<property name="host" value="10.100.1.140"/>
</properties>
<transformer>
<steps/>
</transformer>
<filter>
<rules/>
</filter>
<transportName>LLP Listener</transportName>
</sourceConnector>
<destinationConnectors>
<com.webreach.mirth.model.Connector>
<name>Destination 1</name>
<properties>
<property name="URL" value="jdbc:jtds:sqlserver://DevTest\netsdk:1433/TestDB"/>
<property name="DataType" value="Database Writer"/>
<property name="password" value="test"/>
<property name="host" value="query"/>
<property name="driver" value="net.sourceforge.jtds.jdbc.Driver"/>
<property name="query" value="INSERT INTO Patient(AccountExternal, FirstName, LastName)&amp;#x0D;VALUES (`pd_externalidentifier`, `pd_fname`, `pd_lname`)"/>
<property name="username" value="sa"/>
</properties>
<transformer>
<steps/>
<template>MSH|^~\&amp;amp;|Mirth|1|||2006044535||ADT^A04|603340|D|2.3.1&amp;#x0D;EVN|A04|20060404090742&amp;#x0D;PID|1|800888^^^Mirth^PN|999945682^^^AccMgr^MR^1||TEST^PATIENT MF||19570414|M||W|21 PALM MANOR^^EAST SYRACUSE^NY^130570000^^M|31|||E|M||6635130^^^Mirth^VN^1|000987655|||2|||||NOT A VETERAN|||N&amp;#x0D;PD1||||1335^ALCOTT^KAREN^^^^^^AccMgr^^^^CI|||I&amp;#x0D;NK1|1|TEST^MARGARET|W|21 PALM MANOR^^EAST SYRACUSE^NY^130570000|||Y&amp;#x0D;PV1|1|E|ED^^^1|1|||1281^MARKHAM^JOSEPH^^^^^^AccMgr^^^^CI|1281^LANG^JOE^^^^^^Mirth^^^^CI||ED||||7|S|||62|6635130^^^AccMgr^VN^1|865^SP KOPP|||||||||||||||||||1||A|||20060404090500&amp;#x0D;PV2||^NO||||||20060404090500||||||||||||||||||||||||||||||S&amp;#x0D;DG1|1||^HEADACHE|HEADACHE||A|||||||||0&amp;#x0D;GT1|1|382582|TEST^PATIENT MF||21 PALM MANOR^^EAST SYRACUSE^NY^130570000|||19570414|M|||000987655||||||||11&amp;#x0D;IN1|1|SELF PAY NYS|734|SELF PAY NYS|||||||||||5|TEST^PATIENT MF|1|19570414|21 PALM MANOR^^EAST SYRACUSE^NY^130570000|||||||||||||||||||||||11|M||||||382582&amp;#x0D;IN1|2|SELF PAY|705|SELFPAY|||||||||||5||1&amp;#x0D;IN2|1||000987655&amp;#x0D;</template>
</transformer>
<filter>
<rules/>
<template></template>
</filter>
<transportName>Database Writer</transportName>
</com.webreach.mirth.model.Connector>
</destinationConnectors>
<properties>
<property name="initialState" value="started"/>
<property name="recv_xml_encoded" value="false"/>
</properties>
</com.webreach.mirth.model.Channel>
Reply With Quote
  #6  
Old 09-05-2006, 12:30 PM
nshaik nshaik is offline
Mirth Guru
 
Join Date: Sep 2006
Posts: 302
nshaik
Default Re: Not receiving messages

I also configured Centricity's Millbrook Integration Kit (module which sends HL7 messages out) to send both TCP and FILES. Copy of the message sent as file is as follows:

Code:
0x0BMSH|^~\&amp;|MIK04DEMO^MIK04DEMO^GUID||MirthHL7^MirthHL7^GUID||20060905200732||ADT^A31|AD34894E-1565-48ad-95AA-7249958CA067|P|2.3||||NE
EVN|A31|20060905160732||01
PID|1|560|560||TestPatient^MPM04||19350101000000||||2368 Test St^^TestCity^TT^12345||(123)555-6789CHome^Home^^^^123^5556789^^Home|||Married|||111-11-1111|||||||||||N
PV1|1|O||||||||||||||||||Commercial
GT1|1|399|TestPatient^MPM04||2368 Test St^^TestCity^TT^12345|(123)555-6789CHome^Home^^^^123^5556789^^Home||19350101000000|||Self|111-11-1111||||||||Retired
IN1|1|78|78|United^^^^^&amp;78|P O Box 708499^^Atlanta^GA^30374||(800)257-1009^^^^^800^2571009||||||||Other|TestPatient^MPM04|Self|19350101000000|2368 Test St^^TestCity^TT^12345||IN|1|||N||||||||||||0|||||Retired|||NV||||322
IN2||111-11-1111||||||||||||||||||||||||||||0^0^365|||||||||||||||||||||||||||||||||(123)555-6789CHome^Home^^^^123^5556789^^Home
0x1C
Reply With Quote
  #7  
Old 09-05-2006, 02:31 PM
chrisl chrisl is offline
Mirth Employee
 
Join Date: Aug 2006
Posts: 967
chrisl is an unknown quantity at this point
Default Re: Not receiving messages

Try switching the LLP character code encoding from Hex to ASCII and redeploy.
__________________
Chris Lang
Reply With Quote
  #8  
Old 09-05-2006, 02:45 PM
chrisl chrisl is offline
Mirth Employee
 
Join Date: Aug 2006
Posts: 967
chrisl is an unknown quantity at this point
Default Re: Not receiving messages

Can you email your sample hl7 and your channel export, the forum strips out the brackets.

Thanks,
-Chris
(chrisl [at] webreachinc.com)
__________________
Chris Lang
Reply With Quote
  #9  
Old 09-06-2006, 09:35 AM
nshaik nshaik is offline
Mirth Guru
 
Join Date: Sep 2006
Posts: 302
nshaik
Default Re: Not receiving messages

Requested files emailed.

Thanks
Reply With Quote
  #10  
Old 09-08-2006, 12:01 PM
chrisl chrisl is offline
Mirth Employee
 
Join Date: Aug 2006
Posts: 967
chrisl is an unknown quantity at this point
Default Re: Not receiving messages

Got them, I'll check them out this weekend and give you an update.
__________________
Chris Lang
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Receiving mllp hl7 messages from multiple sources jerchap Support 11 10-18-2011 09:32 PM
Error message when receiving multiple HL7 messages BIOMedIT Support 3 12-12-2008 10:42 AM
Receiving Messages from GE Centricity/MIK chrisl Support 5 08-12-2008 01:32 PM
j2ee application receiving HL7 messages realtime samthakur Development 1 07-28-2008 04:17 AM
Receiving empty alert messages elankreijer Support 3 05-21-2008 11:07 PM


All times are GMT -8. The time now is 03:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation