web stats
Mirth Connect Server 3.2.1.7650 error when logging in as other user then 'admin' - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 03-03-2017, 02:28 AM
Jurjan Jurjan is offline
OBX.1 Kenobi
 
Join Date: Feb 2011
Posts: 37
Jurjan is on a distinguished road
Default Mirth Connect Server 3.2.1.7650 error when logging in as other user then 'admin'

Our client used to give us access to the 'admin' user.

However, that has changed (for security reasons).
We now have users in Mirth that are not the 'admin' user.

This works (as it should), however, everytime we login (in Mirth Connect Administrator), or open the settings section whe get errors we didn't get as admin user:
In a popup:
com.mirth.connect.client.core.ClientException: method failed: HTTP/1.1 500 Server Error
com.mirth.connect.client.core.ServerConnection.exe cutePostMethod(ServerConnection.java:140)
com.mirth.connect.client.core.Client.getUserPrefer ences(Client.java:1202)
com.mirth.connect.client.ui.LoginPanel$8.doInBackg round(LoginPanel.java:449)
com.mirth.connect.client.ui.LoginPanel$8.doInBackg round(LoginPanel.java:407)
javax.swing.SwingWorker$1.call(Unknown Source)
java.util.concurrent.FutureTask.run(Unknown Source)
javax.swing.SwingWorker.run(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker( Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run (Unknown Source)
java.lang.Thread.run(Unknown Source)


In the log file:
ERROR 2017-03-03 11:08:11,379 [qtp1727263881-18488] com.mirth.connect.server.servlets.UserServlet: java.lang.NullPointerException
at com.mirth.connect.server.servlets.UserServlet.isCu rrentUser(UserServlet.java:302)
at com.mirth.connect.server.servlets.UserServlet.doPo st(UserServlet.java:155)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
at org.eclipse.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:652)
at org.eclipse.jetty.servlet.ServletHandler.doHandle( ServletHandler.java:447)
at org.eclipse.jetty.server.session.SessionHandler.do Handle(SessionHandler.java:225)
at org.eclipse.jetty.server.handler.ContextHandler.do Handle(ContextHandler.java:1038)
at org.eclipse.jetty.servlet.ServletHandler.doScope(S ervletHandler.java:374)
at org.eclipse.jetty.server.session.SessionHandler.do Scope(SessionHandler.java:189)
at org.eclipse.jetty.server.handler.ContextHandler.do Scope(ContextHandler.java:972)
at org.eclipse.jetty.server.handler.ScopedHandler.han dle(ScopedHandler.java:135)
at org.eclipse.jetty.server.handler.HandlerList.handl e(HandlerList.java:52)
at org.eclipse.jetty.server.handler.HandlerWrapper.ha ndle(HandlerWrapper.java:116)
at org.eclipse.jetty.server.Server.handle(Server.java :363)
at org.eclipse.jetty.server.AbstractHttpConnection.ha ndleRequest(AbstractHttpConnection.java:483)
at org.eclipse.jetty.server.AbstractHttpConnection.co ntent(AbstractHttpConnection.java:931)
at org.eclipse.jetty.server.AbstractHttpConnection$Re questHandler.content(AbstractHttpConnection.java:9 92)
at org.eclipse.jetty.http.HttpParser.parseNext(HttpPa rser.java:856)
at org.eclipse.jetty.http.HttpParser.parseAvailable(H ttpParser.java:240)
at org.eclipse.jetty.server.AsyncHttpConnection.handl e(AsyncHttpConnection.java:82)
at org.eclipse.jetty.io.nio.SslConnection.handle(SslC onnection.java:196)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint.han dle(SelectChannelEndPoint.java:627)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.r un(SelectChannelEndPoint.java:51)
at org.eclipse.jetty.util.thread.QueuedThreadPool.run Job(QueuedThreadPool.java:608)
at org.eclipse.jetty.util.thread.QueuedThreadPool$3.r un(QueuedThreadPool.java:543)
at java.lang.Thread.run(Unknown Source)

Does anybody know why this happens, and more importantly:
what can we do to stop this from happening?

Thanks,
Jurjan
Reply With Quote
  #2  
Old 03-14-2017, 10:32 AM
AlexNeiva AlexNeiva is offline
Mirth Guru
 
Join Date: Oct 2013
Location: Portugal
Posts: 277
AlexNeiva is on a distinguished road
Default

Try cleaning Java Cache, and if possible delete the users and recreate them again.
I never saw that happening before...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation