web stats
My custom ResponseMap is missing; Mirth Connect v3 RC1 - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 08-12-2013, 08:26 AM
Philoushka Philoushka is offline
OBX.2 Kenobi
 
Join Date: Jan 2009
Posts: 68
Philoushka is an unknown quantity at this point
Default My custom ResponseMap is missing; Mirth Connect v3 RC1

Using v3 RC1

A channel relies on a custom Response built in the destinations to use as a Response in the Source/Response Settings.

In a Destination's Template, we state:

responseMap.put('ResponseHL7v2', ResponseFactory.getSuccessResponse(myhl7));

This entry is not seen on that destination nor any further destinations. The Response entries are all [d1, d2, d3, ]

When this code executes in v2.2.2, it outputs the expected:

SUCCESS: MSH|^~\&|ADM|.......

I also saw the warning about this method being deprecated.

When I switched to use .getSentResponse(myhl7) there's no difference in behaviour.

If I log the values here, I only see "SENT".

How can I use custom Responses in v3 RC1?

Last edited by Philoushka; 08-12-2013 at 08:33 AM.
Reply With Quote
 

Tags
mirth connect, release 3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 05:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation