web stats
Problem using SQL Server 2008 Express for the Mirth DB - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 08-25-2010, 06:32 AM
WillRogers WillRogers is offline
What's HL7?
 
Join Date: Aug 2010
Posts: 4
WillRogers is on a distinguished road
Unhappy Problem using SQL Server 2008 Express for the Mirth DB

Hello all!

I'm new to Mirth Connect but have read enough to get started. I installed Mirth 2 days ago and thought everything was working. Yesterday I couldn't log in to the Connect Admin tool using the Mirth user credentials I created. I eventually decided to reinstall. This morning I had the same issue, so I investigated further and discovered Mirth has been unable to connect to the SQL Server instance I set up using instructions from this web page:

http://codingheadache.com/?p=138

I have tried several things to no avail - my Mirth.log still reports it is unable to connect to the DB. Currently my connection string looks like this in the Server Manager.

jdbc:jtds:sqlserver://localhost:1433/Mirth;instance=SQLEXPRESS

I'm positive the SQL credentials I've supplied are correct and I am able to attach to the database using them and Management Studio Express. "Mirth" is indeed the name of the DB in SQL Server. I've also changed the compatibility for the database to SQL Server 2000 (80) and selected sqlserver as the database Type in the Mirth Connect Server Manager. Each time I've made a change, I've restarted the Mirth Service. So far nothing has worked.

Edit: I forgot to mention I'm running Windows 7 64-bit.

Any suggestions? I've Google'd and searched these forums to no avail.

Thanks in advance for your time,
Will.

Last edited by WillRogers; 08-25-2010 at 06:35 AM. Reason: to mention Windows 7
Reply With Quote
  #2  
Old 08-25-2010, 08:03 AM
gpboutwell gpboutwell is offline
Mirth Newb
 
Join Date: Jul 2010
Location: Norton, KS
Posts: 15
gpboutwell is on a distinguished road
Default

Quote:
jdbc:jtds:sqlserver://localhost:1433/Mirth;instance=SQLEXPRESS
try computername instead of localhost... I know with some technologies I have been forced to use computer name instead of localhost or I was completely unable to connect to SQL Express.

George
Reply With Quote
  #3  
Old 08-25-2010, 09:23 AM
WillRogers WillRogers is offline
What's HL7?
 
Join Date: Aug 2010
Posts: 4
WillRogers is on a distinguished road
Default

George,

Thanks for the reply. I should've mentioned in my original post that I had already tried that. I tried it again after receiving your reply and it's still not working with either the computer name or localhost.
Reply With Quote
  #4  
Old 08-25-2010, 10:13 AM
gpboutwell gpboutwell is offline
Mirth Newb
 
Join Date: Jul 2010
Location: Norton, KS
Posts: 15
gpboutwell is on a distinguished road
Default

. Sorry, Thought it was worth a mention. The only other idea that occurred to me was that you didn't really mention having tried to connect using SQL Management as the user that the Mirth Service is installed/run as. I'm not sure how you would run SQL Management to test that... But it could be the user that Mirth Service is running at can't connect for some reason.


Also, make sure that if you followed codeheadache's directions that SQL Server is set to run in Mixed Authentication Mode (Don't think that is the default anymore) or add ;domain=yourdomain to your connection string.

Finally, what are the detailed messages left in Mirth.log about the connection to the DB not working? Can you past a portion of that?

George

Last edited by gpboutwell; 08-25-2010 at 10:16 AM.
Reply With Quote
  #5  
Old 08-25-2010, 10:56 AM
WillRogers WillRogers is offline
What's HL7?
 
Join Date: Aug 2010
Posts: 4
WillRogers is on a distinguished road
Default

Thanks for the additional suggestions.

I checked and the SQL Express instance is set up for mixed auth. What I meant earlier was that I was able to use the same SQL credentials I supplied to the Mirth Server Manager to connect to the DB using SQL Server Management Studio Express. I wouldn't be able to do this if it was set up just for Windows security. The Mirth Server runs under the Local System account, but if Mirth is using SQL credentials, this shouldn't be a factor.

Here's the Exception (I've stripped out the computer name):
java.sql.SQLException: Unable to get information from SQL Server: [computer name].

There are other exceptions, too, involving being unable to create the schema and unable to initialize channel statistics, but my guess is these are symptoms of not being able to establish a connection.
Reply With Quote
  #6  
Old 08-25-2010, 01:05 PM
gpboutwell gpboutwell is offline
Mirth Newb
 
Join Date: Jul 2010
Location: Norton, KS
Posts: 15
gpboutwell is on a distinguished road
Default

I come accrossed the following FAQ and FAQ item on JTDS's web-site with the error message that you are giving.

http://jtds.sourceforge.net/faq.html#instanceGetInfo

You should check it out and verify that what it is suggesting could be the problem isn't the issue.
Reply With Quote
  #7  
Old 08-26-2010, 04:56 AM
WillRogers WillRogers is offline
What's HL7?
 
Join Date: Aug 2010
Posts: 4
WillRogers is on a distinguished road
Default

George,

That link you sent had the answer! My SQL Server Browser service was not running, so JDTS was unable to retrieve info about the database instance I specified. After starting the service, I stopped getting connection-related errors.

I went ahead and reconfigured the DB for 2008 compatibility and switched the database type to sqlserver2005 in the Mirth Connect Server Manager. Upon restarting the Mirth Service, it created all the tables and appears to be working.

For reference, the variables in question in the Mirth Connect Server Manager now look like this:

Type: sqlserver2005
URL: jdbc:jtds:sqlserver://ComputerName:1433/Mirth;instance=Sqlexpress

Thanks for the help, George!
Reply With Quote
  #8  
Old 09-16-2010, 08:35 AM
magikbanana magikbanana is offline
OBX.2 Kenobi
 
Join Date: Dec 2007
Posts: 79
magikbanana is an unknown quantity at this point
Default

Same problem here, then I got : java.sql.SQLException: Server localhost has no instance named SQLEXPRESS

If you have this error then open Sql Server Configuration Manager, then in SQL Server network config, select Protocols, and Enable TCP/IP. Then it will work !

Hope this will help some else, one day
Reply With Quote
  #9  
Old 09-17-2010, 02:06 AM
nicovn nicovn is offline
OBX.2 Kenobi
 
Join Date: Oct 2006
Location: Belgium
Posts: 64
nicovn
Default

Another issue that you can encounter when using SQLServer Express edition as database for Mirth Connect, is the fact that dynamic ports are configured instead of tcp port 1433 (that is used in the default connection string of Mirth Connect "jdbc:jtds:sqlserver://localhost:1433/mirthdb").

To fix this, blank the "Tcp Dynamic Ports" field in the SqlServer TCP/IP properties screen (see attached screenshot), and fill in 1433 in the TCP Port field.

Hope this helps ...
Attached Images
File Type: jpg 2010-09-1702 11.59.jpg (80.0 KB, 253 views)
__________________
Nico Vannieuwenhuyze

Amaron.be
Reply With Quote
  #10  
Old 10-09-2012, 03:15 AM
vm_mirth vm_mirth is offline
What's HL7?
 
Join Date: Oct 2012
Posts: 1
vm_mirth is on a distinguished road
Default Same problem, but none of these fixes work..

Tried the below:

1) Cleared the java cache and tried to restart the Mirth service, didn't help.
2) Checked the port SQL Server uses - it was 1433, which was the same that Mirth used. Also, the dynamic port was blank.
3) Enabled the TCP/IP ports and also started the SQL Server Browser Service
Reply With Quote
Reply

Tags
login, mirth connect, sql server 2008 express

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 11:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation