web stats
"Failed to configure outbound router" error - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 05-29-2011, 07:53 AM
satyaprakash satyaprakash is offline
Mirth Newb
 
Join Date: May 2011
Posts: 11
satyaprakash is on a distinguished road
Default "Failed to configure outbound router" error

Hi,

I am new to Mirth.
I am trying a HL7v2(File input) to MYSQL Database output.

I got the below error:

ERROR (com.mirth.connect.server.controllers.MuleEngineCo ntroller:341): Failed to configure outbound router.
org.mule.umo.lifecycle.InitialisationException: Initialisation Failure: CONNECTOR:
ConnectDatabaseSCRIPT SOURCE:
Filter/TransformerLINE NUMBER:
12LINE SOURCE:
var mapping;try { mapping = ; }catch (e) { logger.error(e); mapping = '';}channelMap.put('MessageID', validate( mapping , '', new Array()));DETAILS:


Could anyone suggest on the same, pls.

Thanks,
Satya
Reply With Quote
  #2  
Old 05-31-2011, 03:12 PM
geraldb geraldb is offline
Mirth Employee
 
Join Date: Aug 2006
Location: Irvine, CA
Posts: 314
geraldb is an unknown quantity at this point
Default

It looks like your mappings are invalid. You'll notice in the source you have:
Code:
mapping = ;
Are you using a mapper step or JavaScript? Double check that the values that are being set are correct.
__________________
Gerald Bortis | Chief Information Officer | Mirth Corporation
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation