web stats
SOAP error - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-24-2013, 09:39 AM
Chris.ACH Chris.ACH is offline
Mirth Newb
 
Join Date: Sep 2012
Posts: 20
Chris.ACH is on a distinguished road
Default SOAP error

Hello has anyone else encountered this error before or know how I can fix it?

Here is the error:

[2013-09-24 11:15:16,757] ERROR (Server:146): Sep 24, 2013 11:15:16 AM com.sun.xml.internal.ws.client.RequestContext fill
[2013-09-24 11:15:16,773] ERROR (Server:146): WARNING: BindingProvider.SOAPACTION_URI_PROPERTY is set in the RequestContext but is ineffective, Either set BindingProvider.SOAPACTION_USE_PROPERTY to true or enable AddressingFeature


I am using Mirth Connect 2.1.1.5488. This process is working, but it is spamming my Mirth console log with the error. I am querying our state registry for immunization records and they send me a respose to the query. The query and message are in HL7 format but they are embedded in a SOAP envelope. I am using Mirths embedded web service sender to embed the HL7 message in a SOAP envelope and send the query.

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:tem="http://tempuri.org/">
<soap:Header/>
<soap:Body>
<tem:ExecuteHL7Message>
<!--Optional:-->
<tem:userName></tem:userName>
<!--Optional:-->
<temassword></temassword>
<!--Optional:-->
<tem:flatWire><![CDATA[${message.encodedData}]]></tem:flatWire>
</tem:ExecuteHL7Message>
</soap:Body>
</soap:Envelope>

When I receive the response I am using this javascript statement to extract the HL7 messages from the soap envelope.

var soap = new Namespace('http://www.w3.org/2003/05/soap-envelope');
var tempuri = new Namespace('http://tempuri.org/');

tmp = new XML(SerializerFactory.getHL7Serializer().toXML(msg .soap::Body.tempuri::ExecuteHL7MessageResponse.tem puri::ExecuteHL7MessageResult.toString()));

Here is an example of a response message from the state with the HL7 message removed for PHI reasons.

SUCCESS: <?xml version="1.0" encoding="UTF-8" standalone="no"?><soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soap:Header/><soap:Body><ExecuteHL7MessageResponse xmlns="http://tempuri.org/"><ExecuteHL7MessageResult>
HL7 Removed here.
</ExecuteHL7MessageResult></ExecuteHL7MessageResponse></soap:Body></soap:Envelope>


This error make sense to anyone?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation