web stats
Connect to SQLServer on another instance instead of default Derby database - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 07-27-2012, 01:08 PM
doug.schneider doug.schneider is offline
Mirth Newb
 
Join Date: Jul 2011
Posts: 19
doug.schneider is on a distinguished road
Default Connect to SQLServer on another instance instead of default Derby database

We as a company have decided to run Mirth Connect connected to a SQL Server database instance of the default Derby database.

We have been successfully using the SQL Server database when running the standard configuration to a SQL Server

jdbc:jtds:sqlserver://SQLSERVER_IPADDRESS:1433/Mirth

The problem we are having is when we are trying to connect the server a SQL Server database in another instance on the SQL Server. We call our second instance VAL on our servers. We create the Mirth database (empty) on this VAL Instance and can connect to the database with our applications. I can't get the Mirth Connect Service to connect.

I have tried

jdbc:jtds:sqlserver://SQLSERVER_IPADDRESS\VAL:1433/Mirth

and also

jdbc:jtds:sqlserver://SQLSERVER_IPADDRESS/VAL:1433/Mirth

in the Server Manager setup screen.

The error in the log file states that it is an 'Unknown Server'

Has anyone else tried this with success? We are using Mirth Connect 2.1.1
Reply With Quote
  #2  
Old 07-27-2012, 01:16 PM
cory_cole cory_cole is offline
Mirth Guru
 
Join Date: Mar 2012
Posts: 1,161
cory_cole is on a distinguished road
Default

jdbc:jtds:sqlserver://SQLSERVER_IPADDRESS/VAL:1433/Mirth

I don't think you need the :jtds. We use postgress and connection string is...

'jdbcostgresql://localhost:5432/Mirth'
Reply With Quote
  #3  
Old 07-27-2012, 01:21 PM
doug.schneider doug.schneider is offline
Mirth Newb
 
Join Date: Jul 2011
Posts: 19
doug.schneider is on a distinguished road
Default

We are using SQL Server not Postges Sql

The default URL for SQL Server is

jdbc:jtds:sqlserver://localhost:1433/mirthdb
Reply With Quote
  #4  
Old 07-27-2012, 01:37 PM
doug.schneider doug.schneider is offline
Mirth Newb
 
Join Date: Jul 2011
Posts: 19
doug.schneider is on a distinguished road
Default

Found the issue, I needed to add the instance the URL as it's own parameter.

jdbc:jtds:sqlserver://localhost:1433/mirthdb;instance=INSTANCE_NAME

The above sample worked.



Here is the other thread not the same but help.

http://www.mirthcorp.com/community/f...ead.php?t=5500
Reply With Quote
  #5  
Old 10-11-2018, 08:20 AM
lucamarfed lucamarfed is offline
What's HL7?
 
Join Date: Apr 2018
Posts: 4
lucamarfed is on a distinguished road
Default

Many many thanks Doug.
You saved me a lot of time !!!
Regards, Luca.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 06:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Mirth Corporation