web stats
Change encoding - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 01-09-2019, 12:38 AM
abwi abwi is offline
Mirth Newb
 
Join Date: Aug 2009
Location: Belgium
Posts: 7
abwi is on a distinguished road
Default Change encoding

Hi,

We currently have the following issue: we receive HL7 files which are in UTF-8 encoding, these are picked up by a file reader and then send to another system using a tcp sender (MLLP) and this system expects the ISO-8859-1 encoding.

We have tested by setting the encoding as needed in the source and destination connector but this doesn't work as the characters and are replaced by ?.
These characters do exist in the ISO-8859-1 encoding so....

Any idea on how we can get the correct characters in the destionation?
Reply With Quote
  #2  
Old 01-09-2019, 05:19 PM
agermano agermano is offline
Mirth Guru
 
Join Date: Apr 2017
Location: Indiana, USA
Posts: 598
agermano is on a distinguished road
Default

There are multiple ways to specify those characters in Unicode. It's possible they are actually not the same code point(s). Is it replacing the character entirely or keeping the 'e' and putting the question mark after it?

You'll probably need to figure out exactly which characters are coming in. For example, these are all different: èè. Only the first one exists in ISO-8859-1. The others are actually multiple code points and consist of a normal 'e' followed by a combining accent or tone mark.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 02:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation