web stats
Web Service Sender - Error - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 05-08-2013, 11:22 AM
AviMed AviMed is offline
Mirth Newb
 
Join Date: Jan 2013
Posts: 18
AviMed is on a distinguished road
Default Web Service Sender - Error

Hi all
i'm trying to set a channel which it's destination will be my webservice
it's a plain ws (.net) that gets a string. (screen captured attached)

when i'm choosing "invocation type" : two ways - there's an error :
"javax.xml.ws.soap.SOAPFaultException: System.Web.Services.Protocols.SoapException: Server did not recognize the value of HTTP Header SOAPAction: ."

when i'm choosing "one way" - it seems to work... but in reality .. the message never gets to the ws .... (i can see through the iis logs that the request retured with 500 error.)

what i'm doing wrong ?

***

moreover - when i tried WCF service .... it was worse ...
Attached Images
File Type: jpg mirth-ws-prob.jpg (38.1 KB, 32 views)
Reply With Quote
  #2  
Old 05-08-2013, 11:37 AM
AviMed AviMed is offline
Mirth Newb
 
Join Date: Jan 2013
Posts: 18
AviMed is on a distinguished road
Default the IIS logs

date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken

08-05-2013 18:33:56 127.0.0.1 POST /OP.Net.Services.Host.Web/Mirth.asmx - 80 - 127.0.0.1 JAX-WS+RI+2.2.4-b01 500 0 0 357

08-05-2013 18:34:28 127.0.0.1 POST /OP.Net.Services.Host.Web/Mirth.asmx - 80 - 127.0.0.1 JAX-WS+RI+2.2.4-b01 500 0 0 1

08-05-2013 18:34:46 127.0.0.1 POST /OP.Net.Services.Host.Web/Mirth.asmx - 80 - 127.0.0.1 JAX-WS+RI+2.2.4-b01 500 0 0 1
Reply With Quote
  #3  
Old 05-08-2013, 12:37 PM
AviMed AviMed is offline
Mirth Newb
 
Join Date: Jan 2013
Posts: 18
AviMed is on a distinguished road
Angry when i'm choosing WCF and invocation-type : two way

i get this

ERROR-410: Web Service Connector error
ERROR MESSAGE: Error connecting to web service.
javax.xml.ws.soap.SOAPFaultException: The security context token is expired or is not valid. The message was not processed.
at com.sun.xml.internal.ws.fault.SOAP12Fault.getProto colException(Unknown Source)
at com.sun.xml.internal.ws.fault.SOAPFaultBuilder.cre ateException(Unknown Source)
at com.sun.xml.internal.ws.client.dispatch.DispatchIm pl.doInvoke(Unknown Source)
at com.sun.xml.internal.ws.client.dispatch.DispatchIm pl.invoke(Unknown Source)
at com.mirth.connect.connectors.ws.WebServiceMessageD ispatcher.processMessage(WebServiceMessageDispatch er.java:176)
at com.mirth.connect.connectors.ws.WebServiceMessageD ispatcher.doDispatch(WebServiceMessageDispatcher.j ava:106)
at org.mule.providers.AbstractMessageDispatcher$Worke r.run(AbstractMessageDispatcher.java:263)
at org.mule.impl.work.WorkerContext.run(WorkerContext .java:290)
at edu.emory.mathcs.backport.java.util.concurrent.Thr eadPoolExecutor.runWorker(ThreadPoolExecutor.java: 1061)
at edu.emory.mathcs.backport.java.util.concurrent.Thr eadPoolExecutor$Worker.run(ThreadPoolExecutor.java :575)
at java.lang.Thread.run(Unknown Source)
Reply With Quote
  #4  
Old 05-08-2013, 05:17 PM
AviMed AviMed is offline
Mirth Newb
 
Join Date: Jan 2013
Posts: 18
AviMed is on a distinguished road
Lightbulb OK ! i will rephrase :)

Now after I realize few things :

What is the right way to config \ develop a .NET ! web-service \ wcf service which i can use the "web-service sender" connector type @ destination that will work successfully ?

Thanks

p.s.
I ran through couple of posts the suggest that there's a problem with .NET WS .. in regards to mirth "web-service sender" connector type @ destination
Reply With Quote
  #5  
Old 05-09-2013, 05:41 AM
AviMed AviMed is offline
Mirth Newb
 
Join Date: Jan 2013
Posts: 18
AviMed is on a distinguished road
Default Web Service Sender [connector type] !help / .NET WebService

Now after I realize few things :

What is the right way to config \ develop a .NET ! web-service \ wcf service which i can use the "web-service sender" connector type @ destination that will work successfully ?

Thanks

p.s.
I ran through couple of posts the suggest that there's a problem with .NET WS .. in regards to mirth "web-service sender" connector type @ destination
Reply With Quote
  #6  
Old 05-10-2013, 05:16 AM
AviMed AviMed is offline
Mirth Newb
 
Join Date: Jan 2013
Posts: 18
AviMed is on a distinguished road
Default Some body ?

Some body ?
Reply With Quote
  #7  
Old 08-29-2013, 02:37 AM
paul.mciver paul.mciver is offline
OBX.1 Kenobi
 
Join Date: May 2012
Location: UK
Posts: 37
paul.mciver is on a distinguished road
Default Did you work this out?

There was a problem with the sending the Soap action in earlier versions of Mirth 2.*.* but this has been fixed in 2.2.2. That looks like it is the initial error you documented.
Reply With Quote
Reply

Tags
.net, wcf, webservice, webservicesender

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 11:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation