web stats
got an error while processing XML - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Thread Tools Display Modes
Old 10-31-2014, 04:02 AM
johnjohn johnjohn is offline
OBX.1 Kenobi
Join Date: Aug 2014
Posts: 31
johnjohn is on a distinguished road
Default got an error while processing XML

ClinicalDocument xmlns="urn:hl7-org:v3" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="urn:hl7-org:v3 CDA.xsd">

The above is from the XML. When I tested the transaction, got an error of

Transformer error
ERROR MESSAGE: Error evaluating transformer
com.mirth.connect.server.MirthJavascriptTransforme rException:
CHANNEL: CCDA - import
CONNECTOR: sourceConnector
180: }
181: eval('importPackage(' + Packages.java.lang.Class.forName(className).getPac kage().getName() + ')');
182: }
183: }
184: function doScript() {
185: msg = new XML(connectorMessage.getTransformedData());
186: if (msg.namespace('') != undefined) { default xml namespace = msg.namespace(''); } else { default xml namespace = ''; }
187: function filterRule1() {
188: goodLocationList = ['Advocare Ear Nose & Throat Specialists of Morristown'];
DETAILS: TypeError: The prefix "xsi" for attribute "xsi:schemaLocation" associated with an element type "ClinicalDocument" is not bound.
at a5bd9aa0-630f-46e4-971e-bab351252e98:185 (doScript)
at a5bd9aa0-630f-46e4-971e-bab351252e98:223
at com.mirth.connect.server.transformers.JavaScriptFi lterTransformer$FilterTransformerTask.call(JavaScr iptFilterTransformer.java:134)
at com.mirth.connect.server.transformers.JavaScriptFi lterTransformer$FilterTransformerTask.call(JavaScr iptFilterTransformer.java:100)
at java.util.concurrent.FutureTask$Sync.innerRun(Unkn own Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker( Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (Unknown Source)
at java.lang.Thread.run(Unknown Source)

I am using mirth Do I need to load "xsi:schemaLocation="urn:hl7-org:v3 CDA.xsd">"? I am not sure what I am looking at....Thanks,
Reply With Quote
Old 10-31-2014, 06:22 AM
johnjohn johnjohn is offline
OBX.1 Kenobi
Join Date: Aug 2014
Posts: 31
johnjohn is on a distinguished road

I had to do the following to fix the issue:

Goto Source > Set DataType > Properties > Unselect the check box having option "Stripe NameSpace"

Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -8. The time now is 10:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation