web stats
Outbound Message using LLP MSH.12 is null - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 02-01-2007, 11:46 AM
bobbie bobbie is offline
OBX.1 Kenobi
 
Join Date: Nov 2006
Posts: 47
bobbie
Default Outbound Message using LLP MSH.12 is null

NACK sent from the receiver:
Message is not a valid ACK
com.webreach.mirth.model.converters.SerializerExce ption: ca.uhn.hl7v2.HL7Exception: Can't find version ID - MSH.12 is null

I have tried hard coding the value in and it still gives me the same error. Any ideas?
Reply With Quote
  #2  
Old 02-01-2007, 11:27 PM
albertosaez albertosaez is offline
 
Join Date: Sep 2006
Location: Valladolid, Spain
Posts: 842
albertosaez is an unknown quantity at this point
Default Re: Outbound Message using LLP MSH.12 is null

The message refers to the ACK received.

This seems that it's not a good HL7-ACK. Please, check the message with a sniffer (wireshack is a good one) Or desactive the check of the HL7-ACK (set to '0' the ACK timeout in the LLP channel settings).
Reply With Quote
  #3  
Old 02-02-2007, 06:21 AM
bobbie bobbie is offline
OBX.1 Kenobi
 
Join Date: Nov 2006
Posts: 47
bobbie
Default Re: Outbound Message using LLP MSH.12 is null

I did set the ACK timeout to '0' and got the same error.

Is there a certain way that I do the version number.

I have tried hard coding it in a javascript Step.

Is there anything else that I can try?

Is there something that I did not do correctly in my template?
Reply With Quote
  #4  
Old 02-02-2007, 08:31 AM
bobbie bobbie is offline
OBX.1 Kenobi
 
Join Date: Nov 2006
Posts: 47
bobbie
Default Re: Outbound Message using LLP MSH.12 is null

Come to find out it is the message the the reciever sends back to me and he had a bug on his side. I thought it was something wrong with Mirth.
Reply With Quote
  #5  
Old 02-04-2007, 03:50 AM
albertosaez albertosaez is offline
 
Join Date: Sep 2006
Location: Valladolid, Spain
Posts: 842
albertosaez is an unknown quantity at this point
Default Re: Outbound Message using LLP MSH.12 is null

Curios. Setting the ACK timeout to '0' should avoid the ACK reception. Are you using 1.3.2 ?

I'll check it.

By now, there is no option of pre-process the ACK.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Null Pointer Exception arunpriya Support 14 12-27-2015 08:41 PM
Assign null value in channelmap.put ricber Support 4 02-11-2011 09:07 AM
problem with embedded NULL character in hl7 msg lprikockis Support 0 03-12-2009 02:03 PM
Error in Outbound message template tree ASIF Support 1 02-19-2008 12:06 PM
Repeating OBX segments with null data dfelton Support 2 07-09-2007 11:51 AM


All times are GMT -8. The time now is 11:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation