web stats
Mirth REST API - not processing the message to the next channel - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 12-23-2018, 11:09 PM
santoshjami santoshjami is offline
What's HL7?
 
Join Date: Apr 2011
Posts: 2
santoshjami is on a distinguished road
Default Mirth REST API - not processing the message to the next channel

I am using Mirth 3.4.2.
Have a simple channel, that has a Source listener and sends it to subsequent Channel Writer.
Posted a HL7 message against Mirth channel using Swagger end point (POST channels/channelId/messages), got a 204 response.

When I look at dashboard, I only see that the message against Source Connector, but it does not get sent to the Destination.
No other errors I see as well.
Only when I open the message on Dashboard and reprocess, it goes to the Destination channel.

Attaching the screen shot of the dashboard for review. What must be stopping the message from sending to the Destination when posting via API?

Thanks
Santosh Jami
Attached Images
File Type: png MirthEndPoint-Dashboard.png (67.8 KB, 5 views)

Last edited by santoshjami; 12-23-2018 at 11:12 PM. Reason: Attachment
Reply With Quote
Reply

Tags
rest api

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 07:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation