web stats
Problems running connector Tests - Mirth Community

Go Back   Mirth Community > Mirth Connect > Development

Reply
 
Thread Tools Display Modes
  #1  
Old 01-29-2019, 10:11 PM
pmt pmt is offline
Mirth Newb
 
Join Date: Aug 2018
Posts: 6
pmt is on a distinguished road
Default Problems running connector Tests

Hi,
we are considering building our own connectors. While this has worked quite well until now, acceptance testing is a problem.

We are currently developing on top of the 3.4.x branch since most of our deployments still run on 3.4.2

As far as I understand the tests under server/src/com/mirth/connect/connectors/CONNECTORNAME/test are intended to send test messages through a programatically created and deployed channel.

However, when running e.g. the jdbc tests out of box, we get NPE on starting the channel. Stack trace:

java.lang.NullPointerException
at com.mirth.connect.donkey.server.channel.Destinatio nConnector.updateCurrentState(DestinationConnector .java:238)
at com.mirth.connect.donkey.server.channel.Destinatio nConnector.start(DestinationConnector.java:242)

The NPE Happens when trying to access a method of the channel field, which is null




I would like to know if these tests were just broken in 3.4.2 or whether we are missing something.

Last edited by pmt; 01-30-2019 at 01:06 AM.
Reply With Quote
Reply

Tags
connectors, development, testing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 05:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation