web stats
building Mirth Server using build.bat results in error - Mirth Community

Go Back   Mirth Community > Mirth Connect > Development

Reply
 
Thread Tools Display Modes
  #1  
Old 11-06-2019, 07:19 PM
skumar10 skumar10 is offline
What's HL7?
 
Join Date: Sep 2009
Posts: 5
skumar10 is on a distinguished road
Default building Mirth Server using build.bat results in error

I Downloaded mirth sources from github https://github.com/nextgenhealthcare/connect and ran the build.bat. Trying to build this (server) gives error:


C:\dev\gitrepos\connect\server\build.xml:1155: C:\dev\gitrepos\connect\server\setup is not a valid directory

Is the source code and files on https://github.com/nextgenhealthcare/connect correct ? Hoe to resolve this error ?https://www.mirthcorp.com/community/...milies/eek.gif
Reply With Quote
  #2  
Old 11-08-2019, 06:12 PM
agermano agermano is offline
Mirth Guru
 
Join Date: Apr 2017
Location: Indiana, USA
Posts: 1,038
agermano is on a distinguished road
Default

I recently tried to build the source for the first time, but I didn't have any issue. I'm on linux, not windows, but I ran the same command that was in build.bat and it worked. The setup folder is created to hold all of the built components, so I'm not sure what it's complaining about. Permissions maybe? Does you user that is running the script have rights to create that folder?
Reply With Quote
Reply

Tags
build error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 03:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation