web stats
Changing internal Database - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 11-12-2008, 01:41 AM
boesboes boesboes is offline
What's HL7?
 
Join Date: Oct 2008
Posts: 4
boesboes
Default Changing internal Database

I have searched the forum, but couldn't find the answer.

I want a clean mirth install on a sqlserver 2005 database.

How do i proceed?
1: Use de mirth-windows-installer (and the default database is used)
2: Than run the script sqlserver2005-database.sql
is this correct?

than what?
Questions:
1: how do i tell mirth to use the sqlserver database?
Reply With Quote
  #2  
Old 11-12-2008, 04:53 AM
boesboes boesboes is offline
What's HL7?
 
Join Date: Oct 2008
Posts: 4
boesboes
Default Re:Changing internal Database

Worked it out......
Reply With Quote
  #3  
Old 11-12-2008, 05:32 AM
jbartels jbartels is offline
Mirth Guru
 
Join Date: Oct 2006
Posts: 719
jbartels is on a distinguished road
Default Re:Changing internal Database

boesboes wrote:
Quote:
Worked it out......
Can you post your solution? It may help someone else in the future or help the WebReach team improve Mirth.
__________________
Jon Bartels

Zen is hiring!!!!
http://consultzen.com/careers/
Talented healthcare IT professionals wanted. Engineers to sales to management.
Good benefits, great working environment, genuinely interesting work.
Reply With Quote
  #4  
Old 11-12-2008, 06:01 AM
boesboes boesboes is offline
What's HL7?
 
Join Date: Oct 2008
Posts: 4
boesboes
Default Re:Changing internal Database

Of course,

-Instal mirth with default options.
-Run de (sqlserver2005) database script. (within the sql server management studio of course).
-Add a dbuser in sql server.
-Make it db-owner of the mirthdb.
-Start the mirth server manager
With the mirth server manager:
-On tabpage Database, change the type and added username/passwd of the database
-On tappage Service pressed the restart button

Et Voila!

(had one minor problem, it didn't work, read the mirth.log on the server-tabpage -> a typo in de passwd, and corrected it)

But if anyone has a better solution/or sees an improvement, please respond!!

Post edited by: boesboes, at: 11/12/2008 07:03
Reply With Quote
  #5  
Old 11-12-2008, 06:02 AM
Antaris Antaris is offline
OBX.1 Kenobi
 
Join Date: Oct 2006
Posts: 50
Antaris
Default Re:Changing internal Database

Hi !
Have you modified the mirth.properties file to explicitly tell Mirth what DB to use ... something like that or did you use the mirth server manager to do that ?
Code:
jmx.port=1099
https.keypassword=abc12345
mule.config=mule-config.xml
https.port=8443
https.keystore=keystore
mule.queue=${mirthHomeDir}/.mule
mule.boot=mule-boot.xml
server.url=
http.port=8080
https.password=abc12345
configuration.id=MirthConfiguration
database=sqlserver
mule.template=mule-template.xml
http.htdocs=public
(of course before that initiate the SQL DB in SQL Server ...)

Best Regards

Antaris
Reply With Quote
  #6  
Old 11-12-2008, 06:09 AM
boesboes boesboes is offline
What's HL7?
 
Join Date: Oct 2008
Posts: 4
boesboes
Default Re:Changing internal Database

My mirth.properties looks like this:

Code:
#Wed Nov 12 11:19:54 CET 2008
jmx.port=1099
https.keypassword=abc12345
mule.config=mule-config.xml
https.port=8443
https.ciphers=SSL_RSA_WITH_RC4_128_MD5,SSL_RSA_WITH_RC4_128_SHA,TLS_RSA_WITH_AES_128_CBC_SHA,TLS_DHE_RSA_WITH_AES_128_CBC_SHA,TLS_DHE_DSS_WITH_AES_128_CBC_SHA,SSL_DHE_RSA_WITH_3DES_EDE_CBC_SHA,SSL_DHE_DSS_WITH_3DES_EDE_CBC_SHA
https.keystore=keystore
mule.queue=${mirthHomeDir}/.mule
context.path=/
jmx.password=admin
mule.boot=mule-boot.xml
server.url=
http.port=8081
https.password=abc12345
configuration.id=MirthConfiguration
database=sqlserver2005
mule.template=mule-template.xml
http.htdocs=public
So i think the mirth server manager does that....

It also stores the sql-server info in the sqlserver2005-SqlMapConfig.properties - file

Code:
#Wed Nov 12 11:19:54 CET 2008
url=jdbc:jtds:«»sqlserver://localhost:8080/mirthdb
password=*********
database=sqlserver2005
driver=net.sourceforge.jtds.jdbc.Driver
username=mirthdbuser

so the mirth server manager works fine!!!
i didn't have to -vi- any text file :laugh:

o, the mirt version is: Mirth 1.8.0 RC

Post edited by: boesboes, at: 11/12/2008 07:11
Reply With Quote
  #7  
Old 11-12-2008, 06:16 AM
Antaris Antaris is offline
OBX.1 Kenobi
 
Join Date: Oct 2006
Posts: 50
Antaris
Default Re:Changing internal Database

Ok boesboes thx for your reply.
Have nice day (lol i think it is :-D)
Cheers
Antaris
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
x12Transaction internal representation issue rampratapa Support 5 10-02-2008 01:03 PM
DTD for internal XML format? jbartels Development 1 04-19-2008 01:33 PM
Mirth Internal DB kmthayil Support 10 02-18-2008 06:28 AM
Mirth 1.3 - Change internal DB to SQL Server 2000 nshaik Development 1 12-19-2006 10:14 AM
Disable the internal message logging by mirth? norph Support 2 09-29-2006 12:10 AM


All times are GMT -8. The time now is 06:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation