web stats
Client API TCP testConnection - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2018, 01:04 PM
tmcdevitt tmcdevitt is offline
OBX.3 Kenobi
 
Join Date: Oct 2014
Posts: 125
tmcdevitt is on a distinguished road
Exclamation Client API TCP testConnection

I like to use the Client API TCP testConnection POST but I am getting Error 500. I enter channelID, Channel Name and Body into swagger UI but I get the response code 500. I am not sure if all the fields in the body I just enter in the remoteAddress and remotePort is there other fields that needs to be enter within the body?
Reply With Quote
  #2  
Old 04-02-2018, 10:28 AM
agermano agermano is offline
Mirth Guru
 
Join Date: Apr 2017
Location: Indiana, USA
Posts: 795
agermano is on a distinguished road
Default

I think they all need to be set.

It looks like even though the model schema is in JSON, the body content type is xml, but this is a good thing.

I think you can GET /channels/{channelId} then take the channel.destinationConnectors.connector.properties from the connector you are concerned with and use that as your body.
Reply With Quote
Reply

Tags
swagger ui, tcp sender, tcp testconnection

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation