web stats
Web service sender: HTTP transport error - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 06-21-2018, 12:13 PM
neotof neotof is offline
Mirth Guru
 
Join Date: Jun 2011
Posts: 226
neotof is on a distinguished road
Default Web service sender: HTTP transport error

Hello,

I use mirth 3.5.2 in the hospital environment.

I have created a channel which has one destination as 'web service sender'.
After entering WSDL url and clicking on GEt Operations button I got all the available operations in that web service.
I have selected one of the operation from dropdown and after clicking on generate envelope button the correct soap action is displayed it 'SOAP action' field and also the soap envelope is generated successfully.

When a message goes into my channel, I receive as an error message:

QUEUED: Connection refused. [ClientTransportException: erreur de transport HTTP : java.net.ConnectException: Connection refused: connect]

I already have several channels where I use connectors 'web service sender' and I do not have this problem

If I take a soap client and execute exactly the same query, it works



Do you have an idea ?

Thanks in advance
Reply With Quote
  #2  
Old 06-22-2018, 06:16 AM
AlexNeiva AlexNeiva is offline
Mirth Guru
 
Join Date: Oct 2013
Location: Portugal
Posts: 277
AlexNeiva is on a distinguished road
Default

Hello,


one thing i note is on the Location URI.

The path is not the same as WSDL URL... normally should be the same except the "?wsdl"
Give it a try... and put on the WSDL localtion "http://as400:epicura.lan:40000/CPOWebProject/Services/APIWS?wsdl" the same thing that you have in Soap Client URL
__________________
Best Regards,
Alex Neiva

Last edited by AlexNeiva; 06-22-2018 at 06:19 AM.
Reply With Quote
  #3  
Old 06-22-2018, 06:49 AM
siddharth siddharth is offline
Mirth Guru
 
Join Date: Feb 2013
Posts: 835
siddharth is on a distinguished road
Default

Since he is able to cache the WSDL and see the envelope, I think URI is correct. It has to do with the Socket timeout option, try increasing it and see.
__________________
HL7v2.7 Certified Control Specialist!

Last edited by siddharth; 06-22-2018 at 06:50 AM. Reason: foo
Reply With Quote
  #4  
Old 06-24-2018, 12:17 PM
neotof neotof is offline
Mirth Guru
 
Join Date: Jun 2011
Posts: 226
neotof is on a distinguished road
Default

@AlexNeiva

Just!
Thank you, mistake of inattention
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation