web stats
mirth 3.5.2 cannot deploy channels - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-2018, 04:51 AM
manesh manesh is offline
What's HL7?
 
Join Date: May 2018
Posts: 5
manesh is on a distinguished road
Default mirth 3.5.2 cannot deploy channels

hi guys i installed the latest mirth 3.5.2 today and created a channel and when i tried to deploy i get this error
ERROR (com.mirth.connect.server.channel.ErrorTaskHandler :25): java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: javax/activation/UnsupportedDataTypeException
i have no idea what this any help would be appreciated


java version 1.8.0_171
mirth 3.5.2

regards
manesh
Reply With Quote
  #2  
Old 05-11-2018, 05:21 AM
siddharth siddharth is offline
Mirth Guru
 
Join Date: Feb 2013
Posts: 808
siddharth is on a distinguished road
Default

Are you using OpenJDK or Oracle JDK for Java? This is related

http://www.mirthproject.org/communit...d.php?t=217753
__________________
HL7v2.7 Certified Control Specialist!

Last edited by siddharth; 05-11-2018 at 05:21 AM. Reason: foo
Reply With Quote
  #3  
Old 05-11-2018, 07:14 AM
narupley's Avatar
narupley narupley is online now
Mirth Employee
 
Join Date: Oct 2010
Posts: 7,038
narupley is on a distinguished road
Default

That error seems to indicate that you're running the server with Java 9/10. Use Java 8. Java 9/10 support will be coming in 3.6.
__________________
Step 1: JAVA CACHE...DID YOU CLEAR

Nicholas Rupley
Work: 949-237-6069
Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


- How do I foo?
- You just bar.
Reply With Quote
  #4  
Old 05-14-2018, 03:16 AM
manesh manesh is offline
What's HL7?
 
Join Date: May 2018
Posts: 5
manesh is on a distinguished road
Default

Quote:
Originally Posted by narupley View Post
That error seems to indicate that you're running the server with Java 9/10. Use Java 8. Java 9/10 support will be coming in 3.6.
nick must install open JDK 8. or java 1.8.0_171
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Mirth Corporation