web stats
Opening a closed connection - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 07-21-2010, 07:41 AM
tranquil tranquil is offline
Mirth Newb
 
Join Date: Mar 2008
Location: Canada
Posts: 13
tranquil
Default Opening a closed connection

I have a Mirth 1.8.0 channel set up with an LLP sender destination. The parameter "Keep Connection Open" is set to yes. The ack timeout is set to 30000ms. I'm wondering what happens when the receiving system closes its socket. Will Mirth detect this and attempt to open the connection again before sending the next message?

We are running into an issue where the receiving system closes the socket and the next message that Mirth sends will error with the famous 'timeout waiting for ack" error. The message will retry 30-50 times in under a second until the message if finally delivered.

Many thanks
Reply With Quote
  #2  
Old 07-21-2010, 06:11 PM
apatwa apatwa is offline
OBX.2 Kenobi
 
Join Date: May 2010
Location: Nashville, TN
Posts: 94
apatwa is on a distinguished road
Default

Try checking ignore ACK (If you are not planning on receiving any ACKs). What are your send timeout and reconnect interval set to?
Reply With Quote
  #3  
Old 07-22-2010, 07:11 AM
tranquil tranquil is offline
Mirth Newb
 
Join Date: Mar 2008
Location: Canada
Posts: 13
tranquil
Default

I do plan to receive acks so i don't want to ignore them. The problem is no acks are coming back because the socket on the receiving system is closed. Send timeout: 5000, reconnect interval 10000.

It appears that Mirth may not be processing the close request so it continues to attempt to send messages without first sending an open request. I'm wondering what the expected Mirth functionality is...
Reply With Quote
  #4  
Old 07-23-2010, 04:28 AM
nicovn nicovn is offline
OBX.2 Kenobi
 
Join Date: Oct 2006
Location: Belgium
Posts: 64
nicovn
Default

Setting the "Use Persistent Queues" property to Yes on the LLP Sender connector should solve your problem.

Best Regards

Nico

ps: I would also suggest to upgrade to version 1.8.1
__________________
Nico Vannieuwenhuyze

Amaron.be
Reply With Quote
  #5  
Old 07-23-2010, 09:59 AM
tranquil tranquil is offline
Mirth Newb
 
Join Date: Mar 2008
Location: Canada
Posts: 13
tranquil
Default

Thanks for the reply nicovn. Unfortunately i cannot enable persisent queues as it causes a seperate issue within our system. We do plan to upgrade in the near future, do you know if this issue has been resolved in later versions?
Reply With Quote
  #6  
Old 07-29-2010, 02:27 PM
tranquil tranquil is offline
Mirth Newb
 
Join Date: Mar 2008
Location: Canada
Posts: 13
tranquil
Default

Please note that this issue occurs in every version up to 2.0 beta. It also only occurs when the "Keep Connection Open" parameter is set to "yes".

Mirth appears to be unable to interpret the close connection request sent by the other system.
Reply With Quote
  #7  
Old 01-02-2011, 11:29 AM
tfrench tfrench is offline
What's HL7?
 
Join Date: Dec 2010
Posts: 2
tfrench is on a distinguished road
Default

Can anyone comment if this issue has been resolved? I'm using 1.8.1 and am running into this issue. Thus far, based on my testing, I'm not willing to use Persistent Queues. I have not yet testing any of the 2.x releases.
Reply With Quote
  #8  
Old 01-02-2011, 08:38 PM
Hadi Hadi is offline
What's HL7?
 
Join Date: Jul 2010
Posts: 5
Hadi is on a distinguished road
Default

Are you receiving the ACK on the same port?
Reply With Quote
  #9  
Old 01-03-2011, 10:52 AM
jacobb jacobb is offline
Mirth Employee
 
Join Date: Aug 2006
Location: Irvine, CA
Posts: 1,218
jacobb is an unknown quantity at this point
Default

I believe this issue was resolved in 2.0.0 Beta 2:

http://www.mirthcorp.com/community/i...wse/MIRTH-1442
__________________
Jacob Brauer
Director, Software Development
NextGen Healthcare

Reply With Quote
  #10  
Old 02-01-2011, 12:02 PM
tranquil tranquil is offline
Mirth Newb
 
Join Date: Mar 2008
Location: Canada
Posts: 13
tranquil
Default

Quote:
Originally Posted by jacobb View Post
I believe this issue was resolved in 2.0.0 Beta 2:

http://www.mirthcorp.com/community/i...wse/MIRTH-1442
These are different issues Jacob. The issue i have reported here is not related to mis-matched acks. The issue is Mirth tries to send a message over a closed connection.
Reply With Quote
Reply

Tags
1.8.0, connection, socket

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 04:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation