web stats
MLLP apears to not receive messages - Mirth Community

Go Back   Mirth Community > Mirth Connect > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 04-06-2011, 01:46 PM
mszulzyk mszulzyk is offline
What's HL7?
 
Join Date: Dec 2010
Posts: 2
mszulzyk is on a distinguished road
Default MLLP apears to not receive messages

I have a MLLP server configured.
The server works fine most of the time, but sometimes it take a long time (up to ten minutes) to receive the messages sent by other application.
I've tested the connection with a sniffer and I cann saw that all the messages arrives at time to the computer, but some of the messages are not shown in the dashboard/channel messages screen.
after a while the messages are shown.

Can anybody help me with this issue?
Reply With Quote
  #2  
Old 04-07-2011, 10:25 AM
mszulzyk mszulzyk is offline
What's HL7?
 
Join Date: Dec 2010
Posts: 2
mszulzyk is on a distinguished road
Default Solved

The problem was solved when I realized that the sender application didn't close the connections and mirth only allow 10 connections per channel.
I configure the connector to close the incoming connection after ack were sent.
Reply With Quote
Reply

Tags
connection, mllp, timeout

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation