web stats
Running Mirth Connect Administrator 2.x and 3.x at the same Machine: There was an err - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 11-09-2018, 12:56 AM
manpakhong manpakhong is offline
What's HL7?
 
Join Date: Nov 2018
Posts: 1
manpakhong is on a distinguished road
Lightbulb Running Mirth Connect Administrator 2.x and 3.x at the same Machine: There was an err

Problem:
========
Mirth Connect Administrator 2.x is running java version 1.7.
Mirth Connect Administrator 3.x is running java version 1.8.

When two java versions are installed at Windows. When using Mirth Connect Administrator 2.x to do connection to Mirth 2.x server, the following error message is appeared:

There was an error connecting to the server at the specified address. Please verify that the server is up and running.

Solution:

run mirth connect administrator2.x and 3.x
==========================================
to run 2.x
-----------
find Java @control panel

"Java" tag -> View -> User ->

disable 1.8
enable 1.7

check "Mirth startup.bat"
"C:\Program Files\Java\jdk1.7.0_80\bin\java.exe" -server -Xrs -Xms256m -Xmx256m -Djava.awt.headless=true -Dfile.encoding=UTF8 -Duser.language=en -jar mirth-launcher.jar
ensure java version used to trigger server is java 1.7

go to http://locahost:6480
download webstart.jnlp

run once and then the shortcut will be genertated
change the javaws.exe to java 1.7 path
from:
C:\Windows\System32\javaws.exe -localfile "C:\Users\davephman\AppData\LocalLow\Sun\Java\Depl oyment\cache\6.0\43\5d8e80ab-526ff56e"
to:
"C:\Program Files\Java\jdk1.7.0_80\bin\javaws.exe" -localfile "C:\Users\davephman\AppData\LocalLow\Sun\Java\Depl oyment\cache\6.0\43\5d8e80ab-526ff56e"

to run 3.x
-----------
find Java @control panel

"Java" tag -> View -> User ->

enable 1.8
disable 1.7

check "Mirth startup.bat"
"C:\Program Files\Java\jdk1.8.0_192\bin\java.exe" -server -Xms512m -Xmx512m -XX:MaxPermSize=256m -Djava.awt.headless=true -Dapple.awt.UIElement=true -jar mirth-server-launcher.jarensure java version used to trigger server is java 1.8

go to http://locahost:6480
download webstart.jnlp

run once and then the shortcut will be genertated
change the javaws.exe to java 1.8 path
from:
C:\Windows\System32\javaws.exe -localfile "C:\Users\xxxxxx\AppData\LocalLow\Sun\Java\Deploym ent\cache\6.0\43\5d8e80ab-526ff56e"
to:
"C:\Program Files\Java\jdk1.8.0_192\bin\javaws.exe" -localfile "C:\Users\xxxxx\AppData\LocalLow\Sun\Java\Deployme nt\cache\6.0\12\69abfc0c-74d3a62e"

manpakhong@hotmail.com
Man Pak Hong, Dave
Reply With Quote
  #2  
Old 11-09-2018, 11:54 AM
agermano agermano is offline
Mirth Guru
 
Join Date: Apr 2017
Location: Indiana, USA
Posts: 530
agermano is on a distinguished road
Default

You could trying using the new Administrator Launcher (see announcement thread in forum.) It doesn't use javaws at all, and let's you easily configure different JVMs per connection.
Reply With Quote
Reply

Tags
error connecting, mirth connect 2

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Mirth Corporation