web stats
HTTP Sender does nothing - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 10-08-2019, 11:32 AM
tjoyner1 tjoyner1 is offline
What's HL7?
 
Join Date: Sep 2019
Posts: 3
tjoyner1 is on a distinguished road
Question HTTP Sender does nothing

Greetings

I am in a test phase for a channel setup. I have a source connector of JavaScript Reader that has a mundane useless variable just to trigger the polling. I have an HTTP sender with a GET to a public URL designed for API's and learning about API's, so nothing is confidential or anything of the sort. The imported cert are fine, everything looks like it should be working. On the dashboard the channel connection log goes from reading to idle as you'd expect for in between the poll intervals. The HTTP Sender destination should do something but nothing happens... No error, no nothing. I set up a second destination as a nowhere channel writer just to see any output, but nothing happens.

The ultimate goal is to have Mirth perform a GET to a URL, then take that data and write to another destination SQL writer... but before I can do any of that, I have to prove that I can do a simple GET from a URL...

I'm not proficient in JS or API... I do have lots of help where I am with my team coworkers.. but hoping someone here in the community can assist.

Thank you.
Reply With Quote
  #2  
Old 10-08-2019, 12:00 PM
pacmano pacmano is offline
OBX.2 Kenobi
 
Join Date: Oct 2009
Location: Texas
Posts: 86
pacmano is on a distinguished road
Default

Paste some screenshots. Your current post is like saying "my car won't start".

I'd post your source side and destination connector screenshots.
__________________
Mirth 3.8.0 / PostgreSQL 11 / Ubuntu 18.04
Diridium Technologies, Inc.
https://diridium.com
Reply With Quote
  #3  
Old 10-09-2019, 06:54 AM
tjoyner1 tjoyner1 is offline
What's HL7?
 
Join Date: Sep 2019
Posts: 3
tjoyner1 is on a distinguished road
Default

Greetings

So the original issue was resolved, I had a few configuration issues. I now get a desired response in this test channel / destination. But now I am running into another issue for which I am having a new "new guy blunder" configuration dilemma.

The typical way the flow works is source sends to each destination a message and that destination process it.

However, I am trying to configure my channel in a way, that the top destination performs an API "GET" using the HTTP Sender connector type, then the next destination takes that first destinations response and processes it. And this daisy chain should be repeatable as many times as needed...

So instead of destination 2 getting a message from the source connector, I want destination 2 to receive the message from the response portion of the message from destination 1 and process it another way such as file writing.

I am positive I can do this, but have forgotten how... or am having trouble looking for the solution...

Thoughts?

Last edited by tjoyner1; 10-09-2019 at 08:13 AM.
Reply With Quote
Reply

Tags
api, api call, does nothing, get request, http sender

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 09:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation