web stats
Connect 3.0 web service response - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 07-23-2013, 01:13 PM
sandersmr sandersmr is offline
OBX.2 Kenobi
 
Join Date: Feb 2013
Posts: 71
sandersmr is on a distinguished road
Default Connect 3.0 web service response

I decided to try out the 3.0 RC1 version of Mirth Connect and made a web service sender destination to try out some things with CCDs. I noticed that when I tried to grab the soap response, the encoded XML response was stripped of namespaces. I checked the Response and Processed Response of the destination and noticed the latter has stripped the namespaces off while the former still has them. Is there a reason why it does this, and how do I go about getting the non-processed response?

Response:
Code:
...
<ClinicalDocument xmlns="urn:hl7-org:v3" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><realmCode code="US" />
...
Processed Response:
Code:
...
<ClinicalDocument  ><realmCode code="US" />
...
Reply With Quote
  #2  
Old 07-23-2013, 01:18 PM
narupley's Avatar
narupley narupley is offline
Mirth Employee
 
Join Date: Oct 2010
Posts: 7,126
narupley is on a distinguished road
Default

Try this. Go to the Set Data Types dialog of the channel, and expand the node for your destination so you can see the Response entry. Then on the inbound HL7 v3.x or XML data type for that row, uncheck "Strip Namespaces".
__________________
Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

Nicholas Rupley
Work: 949-237-6069
Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


- How do I foo?
- You just bar.
Reply With Quote
  #3  
Old 07-24-2013, 05:47 AM
sandersmr sandersmr is offline
OBX.2 Kenobi
 
Join Date: Feb 2013
Posts: 71
sandersmr is on a distinguished road
Default

That fixed it. I had unchecked Strip Namespaces on the outbound properties of the destination, but hadn't made any changes to the Response portion of it.

Thanks
Reply With Quote
  #4  
Old 08-07-2014, 07:46 AM
dgtombs dgtombs is offline
Mirth Newb
 
Join Date: Jul 2012
Posts: 10
dgtombs is on a distinguished road
Default

Thanks for the fix. My channel actually broke upon upgrade from 2.2.2 to 3.0.3. I guess 2.2.2 didn't strip the namespaces from the response by default, but 3.0.3 does. Perhaps this could be added to the Upgrade Guide?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Mirth Corporation