web stats
Parsing excel using POI 4.0.0 gives xmlbeans library conflict - Mirth Community

Go Back   Mirth Community > Mirth Connect > Support

Reply
 
Thread Tools Display Modes
  #1  
Old 07-04-2019, 08:24 AM
kristof.taveirne kristof.taveirne is offline
Mirth Newb
 
Join Date: Apr 2010
Posts: 9
kristof.taveirne is on a distinguished road
Default Parsing excel using POI 4.0.0 gives xmlbeans library conflict

Hi,

When trying to parse a XLSX file using POI 4.0.0 I get a NoSuchMethodError on
org.apache.xmlbeans.XmlOptions.setEntityExpansionL imit(I)

I'm including xmlbeans-3.0.1.jar in the custom-lib folder, which is the version of xmlbeans that's included in the .bin package of POI 4.0.0.

So, it looks like there is already a version of xmlbeans on the classpath.
I would like to find out which version of xmlbeans is used, so I can use the appropriate version of POI that is compatible with that version.

I'm using Mirth Connect 3.6.2.

Is there a way to find the conflicting library?

How do you typically deal with these kind of issues?

Thank you,
Kristof Taveirne
Reply With Quote
Reply

Tags
excel, poi, xmlbeans

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 12:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Mirth Corporation