Mirth Connect
  1. Mirth Connect
  2. MIRTH-1186

Cannot remotely connect to JMX without tweaking host's hostname/IP resolution

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: Server
    • Labels:
      None

      Description

      This is caused by a Java bug. The default socket listener created by the factory grabs the local host name.

      http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6425769

      A fix would be to create a custom socket factory that pulls that host name from an appliance property:

      http://java.sun.com/j2se/1.5.0/docs/guide/rmi/socketfactory/index.html

        Activity

        Hide
        Gerald Bortis added a comment -
        Show
        Gerald Bortis added a comment - Possible fix: http://vafer.org/blog/20061010091658/
        Hide
        Steve Kehlet added a comment - - edited

        For future reference, this is a tricky issue. Java's RMI system tells clients, in-band, what hostname to use when connecting to services like JMX. Before this patch, Mirth Connect was coded to use "localhost". However it appears RMI attempts to resolve the system's hostname to an IP and use that. Or some combination, perhaps if one or the other is "localhost". This commit and setting jmx.host seems to override the hostname resolution mechanism. Previously, I would use -Djava.rmi.server.hostname=x.x.x.x to override this. This commit seems to do the same thing.

        Show
        Steve Kehlet added a comment - - edited For future reference, this is a tricky issue. Java's RMI system tells clients, in-band, what hostname to use when connecting to services like JMX. Before this patch, Mirth Connect was coded to use "localhost". However it appears RMI attempts to resolve the system's hostname to an IP and use that. Or some combination, perhaps if one or the other is "localhost". This commit and setting jmx.host seems to override the hostname resolution mechanism. Previously, I would use -Djava.rmi.server.hostname=x.x.x.x to override this. This commit seems to do the same thing.
        Hide
        Jacob Brauer added a comment -

        This was fixed in 2.0.0

        Show
        Jacob Brauer added a comment - This was fixed in 2.0.0

          People

          • Assignee:
            Gerald Bortis
            Reporter:
            Gerald Bortis
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development