Mirth Connect
  1. Mirth Connect
  2. MIRTH-1418

InstanceAlreadyExistsException at channel deployment

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0 Beta 1, 2.0.0 Beta 2, 2.0.0 RC 1, 2.0.0 RC 2
    • Fix Version/s: 2.0.0
    • Component/s: Server
    • Labels:
      None
    • Operating System:
      Windows XP

      Description

      I created a simple test channel, that picks local files and sends an email with the file content.
      When I tried deploying, it did not deploy, for an authentic reason. When I rectified that, and tried to redeploy, I have been getting this error and the channel doesnt deploy.

      [2010-05-10 14:03:15,468] ERROR (com.mirth.connect.server.controllers.MuleEngineController:174): Error registering channel.
      javax.management.InstanceAlreadyExistsException: MirthConfiguration:type=control,name=c97e329b-c47c-4db1-9be0-2ccdbeac37e6_source_connectorService
      at com.sun.jmx.mbeanserver.Repository.addMBean(Unknown Source)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.internal_addObject(Unknown Source)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerDynamicMBean(Unknown Source)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerObject(Unknown Source)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(Unknown Source)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(Unknown Source)
      at org.mule.management.agents.JmxAgent.registerConnectorService(JmxAgent.java:436)
      at com.mirth.connect.server.controllers.MuleEngineController.registerConnector(MuleEngineController.java:485)
      at com.mirth.connect.server.controllers.MuleEngineController.configureInboundRouter(MuleEngineController.java:245)
      at com.mirth.connect.server.controllers.MuleEngineController.registerChannel(MuleEngineController.java:201)
      at com.mirth.connect.server.controllers.MuleEngineController.deployChannels(MuleEngineController.java:172)
      at com.mirth.connect.server.Mirth.deployChannels(Mirth.java:222)
      at com.mirth.connect.server.Mirth.run(Mirth.java:130)

      [2010-05-10 14:03:15,468] ERROR (com.mirth.connect.server.controllers.MuleEngineController:564): Error unregistering channel component.
      org.mule.umo.model.ModelException: The required object/property "UMO Descriptor" is null
      at org.mule.impl.model.AbstractModel.unregisterComponent(AbstractModel.java:188)
      at com.mirth.connect.server.controllers.MuleEngineController.unregisterChannel(MuleEngineController.java:562)
      at com.mirth.connect.server.controllers.MuleEngineController.deployChannels(MuleEngineController.java:177)
      at com.mirth.connect.server.Mirth.deployChannels(Mirth.java:222)
      at com.mirth.connect.server.Mirth.run(Mirth.java:130)

      How do we get rid of this?

      1. settings1.JPG
        62 kB
      2. settings2.JPG
        92 kB

        Activity

        Deepa Rao added a comment -

        Saw the InstanceAlreadyExistsException again today on the Mirth Connect Version - 2.0.1.5164 .
        Occurred when I included an output JMSWriter connector with a new queue name on a remote MQ server. I have the brokerURL property set and we access a bunch of other queues from the same channel, in the same way, but from other destinations.

        Mirth Connect restart didn't help. Manually creating the queue on the remote MQ server did not work either.

        Deepa Rao added a comment -

        Well, the channel got deployed when I restarted Mirth Connect again after I created the queue manually.

        Jacob Brauer added a comment -

        MIRTH-1695 - Separated the creation and the registering of transformers so the destination's FilteringMulticastingRouter is created and can be unregistered properly when deployment fails.

        Jacob Brauer added a comment -

        Deepa,

        Do you have a way to reproduce the InstanceAlreadyExistsException after a failed deploy with a JMS Writer or Reader? If you could attach a channel that causes it that would be very helpful.

        Jacob Brauer added a comment -

        Moving this issue back to 2.0.0 and closing it because we were unable to reproduce the new error. If a test case to reproduce the InstanceAlreadyExistsException is submitted again it should be done under a new issue.


          People

          • Assignee:
            Jacob Brauer
            Reporter:
            Deepa Rao
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development