Mirth Connect
  1. Mirth Connect
  2. MIRTH-3855

"Always choose" option for importing code template libraries along with channels affects the export user preference

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.3.0, 3.3.1
    • Fix Version/s: 3.4.0, 3.3.2
    • Component/s: Administrator
    • Labels:
      None

      Description

      Export code template preference is being updated while selecting "Always choose this option by default" during Import

      1. Fixed_MC332.png
        188 kB
      2. Issue_MC331.png
        216 kB

        Activity

        Nick Rupley added a comment -

        Fixed in revisions 7872/7873.

        Minh Tran added a comment - - edited

        Server(s) and URLs Used: virtual Window 7 with JRE version 1.8.0_71-b15
        Version(s)/Build(s) to reproduce failure: mirthconnect-3.3.1.7856.b91-windows-x64
        Version(s)/Build(s) to verify fixes:
        mirthconnect-3.3.1.7901.b100-windows-x64
        mirthconnect-3.4.0.7892.b1858-windows-x64
        How Tested (list tests run):

        1. Mirth Connect Settings > Administrator > System Preferences > Set the followings:
          Import code template libraries with channels = “Ask”
          Export code template libraries with channels = “Ask”
        2. Save & Refresh, take screenshot for record
        3. Mirth Connect Channels > Import Channel > select a channel with Code Template to import
        4. Select option “Always choose this option by default in the future” & click YES to import
        5. Save Channel
        6. Mirth Connect Settings > Administrator > System Preferences > Verify Import & Export settings

        Verified Fixed: Import preference is properly updated as selected

        Minh Tran added a comment -

        Verified Import Code Template preference is correctly updated with MC331.7901.b100 & MC340.7892.b1858

        Minh Tran added a comment - - edited

        The original issue was fixed, however, the "Always choose" option does not take affect in the current selection (if import more than one channel at the same time, each with code template, user will get prompted for each one, previous preference will be overwritten) . Need DEV's feedback if this behavior should be corrected.

        Nick Rupley added a comment -

        Hmm I think that's fine for now. The reason this is happening is because the code that imports channels is called via SwingUtilities.invokeLater. That's necessary because of a separate bug only on OSX. However it means that in this case, if you multi-import, it will show you that code template libraries dialog for every channel, but only the first time.

        Minh Tran added a comment -
        1. Original issue is FIXED
        2. Note on observation:
          "Always choose" option does not take affect in the current import selection (if import more than one channel at the same time, user will get prompted for each one, previous preference will be overwritten).

          People

          • Assignee:
            Nick Rupley
            Reporter:
            Nick Rupley
            Assigned QA:
            Minh Tran
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: