Mirth Connect
  1. Mirth Connect
  2. MIRTH-3876

Remove all messages Message task removes messages from two channels rather than one

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.3.0, 3.3.1
    • Fix Version/s: 3.4.0, 3.3.2
    • Component/s: Administrator
    • Labels:
      None
    1. screenshot-1.png
      24 kB
    2. screenshot-2.png
      118 kB
    3. screenshot-3.png
      25 kB
    4. TestSteps.png
      500 kB

      Activity

      Michael Pang added a comment -

      1. Using the shift key, select three channels
      2. Open one channel, remove all messages from message tasks
      3. View dashboard to see that messages have been removed from two channels

      Michael Pang added a comment -

      The second channel cleared seems unpredictable. Selecting channel Sample - Hello World v3 in step two causes messages to clear in channels Sample - Hello World v3 and HL7 to MR

      Michael Pang added a comment -

      Event log shows a "Clear messages" event on two channel IDs

      Kirby Knight added a comment -

      This is a serious issue. We lost two weeks of data. When you search for message within a channel and Remove All Messages or Remove Results, there should be no way you are deleting messages from another channel.

      Nick Rupley added a comment - - edited

      Looks like this regression was added with MIRTH-2288. As a workaround in the meantime, just make sure not to have any channel selected on the Channels view first. You can do that by clicking on the blank space below the channels in the table. Or, create a new dummy channel, select it, and delete it.

      Eduardo Armendariz added a comment -

      Fixed in revision 7895. Rewrote logic in doRemoveAllMessages method so it no longer uses the channel list selection.

      Kirby Knight added a comment -

      Thanks Eduardo,

      Can you tell me how I know which update this fix will be included in?

      Minh Tran added a comment - - edited

      OS(s) and JRE version: virtual Window 7 with JRE version 1.8.0_71-b15
      Version(s)/Build(s) to reproduce failure: mirthconnect-3.3.1.7856.b91-windows-x64
      Version(s)/Build(s) to verify fixes: mirthconnect-3.3.1.7901.b100-windows-x64
      How Tested (list tests run):

      1. Create 3 test channels with Source/Destination = JS Reader/Writer
        All without poll once on start
        Test1 = send every 10 seconds
        Test2 = send every 20 seconds
        Test3 = send every 30 seconds
      2. Channels > Deploy test channels
      3. Channels > select Test1, make sure the channel line is highlighted
      4. Dashboard > Stop test channels > Record the current statistics
      5. Dashboard > select Test3 > Remove All Messages > Record the new statistics
      6. Events > select the latest Name = “Clear messages”, verify “channelIds” value

      Observation: In MC331.7856

      1. Messages were removed from both Test1 and Test3 (only select to remove msg from Test3)
      2. “Clear Messages” event listed channelsID of both Test3 and Test1
      3. Whichever channel selected/highlighted in Channels view is being affected during “Remove All Messages” operation.

      Verified Fixed: problem no longer exhibits in MC332 (3.3.1.7901.b100)

      1. Only messages from Test3 were removed
      2. “Clear messages” Event showed the correct channelID for the operation
      Minh Tran added a comment -

      Verified FIX with mirthconnect-3.3.1.7901.b100-windows-x64


        People

        • Assignee:
          Eduardo Armendariz
          Reporter:
          Michael Pang
          Assigned QA:
          Minh Tran
        • Votes:
          1 Vote for this issue
          Watchers:
          7 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: