Mirth Connect
  1. Mirth Connect
  2. MIRTH-4294

Channels from 3.4 or earlier fail to import

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.6.0
    • Fix Version/s: 3.7.0, 3.6.1
    • Component/s: None
    • Labels:
      None

      Description

      Error importing channel from version 3.4 or earlier
      ERROR:

      "Channel has an unknown problem. Channel import aborted

        Issue Links

          Activity

          Minh Tran added a comment -

          OS(s) and JRE version: virtual Window 7 with JRE version 1.8.0_121
          Version(s)/Build(s) to reproduce failure: mirthconnect-3.6.0.b2287-windows-x64.zip
          Version(s)/Build(s) to verify fixes: mirthconnect-3.6.0.b2290-windows-x64.zip
          How Tested:

          1. Launch MC administrator
          2. Import a channel from version 3.4.0 and one from 3.3.2
          3. Verify channels are imported successfully
          Minh Tran added a comment -

          Observed Failure

          com.mirth.connect.donkey.util.xstream.SerializerException: com.thoughtworks.xstream.converters.ConversionException: null : null
          ---- Debugging information ----
          cause-exception     : java.lang.NullPointerException
          cause-message       : null
          class               : com.mirth.connect.model.Channel
          required-type       : com.mirth.connect.model.Transformer
          converter-type      : com.mirth.connect.model.converters.ChannelConverter
          path                : /list/channelSummary/channelStatus/channel/sourceConnector/transformer/steps
          class[1]            : com.mirth.connect.model.ChannelStatus
          converter-type[1]   : com.thoughtworks.xstream.converters.reflection.ReflectionConverter
          class[2]            : com.mirth.connect.model.ChannelSummary
          class[3]            : java.util.ArrayList
          converter-type[2]   : com.thoughtworks.xstream.converters.collections.CollectionConverter
          version             : not available
          -------------------------------
          com.mirth.connect.client.core.ClientException: com.mirth.connect.donkey.util.xstream.SerializerException: com.thoughtworks.xstream.converters.ConversionException: null : null
          ---- Debugging information ----
          cause-exception     : java.lang.NullPointerException
          cause-message       : null
          class               : com.mirth.connect.model.Channel
          required-type       : com.mirth.connect.model.Transformer
          converter-type      : com.mirth.connect.model.converters.ChannelConverter
          path                : /list/channelSummary/channelStatus/channel/sourceConnector/transformer/steps
          class[1]            : com.mirth.connect.model.ChannelStatus
          converter-type[1]   : com.thoughtworks.xstream.converters.reflection.ReflectionConverter
          class[2]            : com.mirth.connect.model.ChannelSummary
          class[3]            : java.util.ArrayList
          converter-type[2]   : com.thoughtworks.xstream.converters.collections.CollectionConverter
          version             : not available
          -------------------------------
          at com.mirth.connect.client.core.Client$2.invoke(Client.java:286)
          at com.sun.proxy.$Proxy55.getChannelSummary(Unknown Source)
          at com.mirth.connect.client.core.Client.getChannelSummary(Client.java:971)
          at com.mirth.connect.client.ui.ChannelPanel.retrieveChannels(ChannelPanel.java:581)
          at com.mirth.connect.client.ui.ChannelPanel.retrieveChannels(ChannelPanel.java:576)
          at com.mirth.connect.client.ui.Frame.updateChannel(Frame.java:1544)
          at com.mirth.connect.client.ui.ChannelPanel.importChannel(ChannelPanel.java:1584)
          at com.mirth.connect.client.ui.ChannelPanel.importChannel(ChannelPanel.java:1438)
          at com.mirth.connect.client.ui.ChannelPanel.importChannel(ChannelPanel.java:1434)
          at com.mirth.connect.client.ui.ChannelPanel.doImportChannel(ChannelPanel.java:1413)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at sun.reflect.misc.Trampoline.invoke(Unknown Source)
          at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at sun.reflect.misc.MethodUtil.invoke(Unknown Source)
          at java.beans.EventHandler.invokeInternal(Unknown Source)
          at java.beans.EventHandler.access$000(Unknown Source)
          at java.beans.EventHandler$1.run(Unknown Source)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.beans.EventHandler.invoke(Unknown Source)
          at com.sun.proxy.$Proxy46.actionPerformed(Unknown Source)
          at org.jdesktop.swingx.action.BoundAction.actionPerformed(BoundAction.java:231)
          at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
          at org.jdesktop.swingx.JXHyperlink.fireActionPerformed(JXHyperlink.java:264)
          at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
          at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
          at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
          at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
          at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
          at java.awt.Component.processMouseEvent(Unknown Source)
          at javax.swing.JComponent.processMouseEvent(Unknown Source)
          at java.awt.Component.processEvent(Unknown Source)
          at java.awt.Container.processEvent(Unknown Source)
          at java.awt.Component.dispatchEventImpl(Unknown Source)
          at java.awt.Container.dispatchEventImpl(Unknown Source)
          at java.awt.Component.dispatchEvent(Unknown Source)
          at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
          at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
          at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
          at java.awt.Container.dispatchEventImpl(Unknown Source)
          at java.awt.Window.dispatchEventImpl(Unknown Source)
          at java.awt.Component.dispatchEvent(Unknown Source)
          at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
          at java.awt.EventQueue.access$500(Unknown Source)
          at java.awt.EventQueue$3.run(Unknown Source)
          at java.awt.EventQueue$3.run(Unknown Source)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
          at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
          at java.awt.EventQueue$4.run(Unknown Source)
          at java.awt.EventQueue$4.run(Unknown Source)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
          at java.awt.EventQueue.dispatchEvent(Unknown Source)
          at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
          at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
          at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
          at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
          at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
          at java.awt.EventDispatchThread.run(Unknown Source)
          Caused by: com.mirth.connect.donkey.util.xstream.SerializerException: com.thoughtworks.xstream.converters.ConversionException: null : null
          ---- Debugging information ----
          cause-exception     : java.lang.NullPointerException
          cause-message       : null
          class               : com.mirth.connect.model.Channel
          required-type       : com.mirth.connect.model.Transformer
          converter-type      : com.mirth.connect.model.converters.ChannelConverter
          path                : /list/channelSummary/channelStatus/channel/sourceConnector/transformer/steps
          class[1]            : com.mirth.connect.model.ChannelStatus
          converter-type[1]   : com.thoughtworks.xstream.converters.reflection.ReflectionConverter
          class[2]            : com.mirth.connect.model.ChannelSummary
          class[3]            : java.util.ArrayList
          converter-type[2]   : com.thoughtworks.xstream.converters.collections.CollectionConverter
          version             : not available
          -------------------------------
          at com.mirth.connect.model.converters.ObjectXMLSerializer.createSerializerException(ObjectXMLSerializer.java:417)
          at com.mirth.connect.model.converters.ObjectXMLSerializer.deserializeList(ObjectXMLSerializer.java:372)
          at com.mirth.connect.client.core.api.providers.XmlMessageBodyReader.readFrom(XmlMessageBodyReader.java:48)
          at org.glassfish.jersey.message.internal.ReaderInterceptorExecutor$TerminalReaderInterceptor.invokeReadFrom(ReaderInterceptorExecutor.java:256)
          at org.glassfish.jersey.message.internal.ReaderInterceptorExecutor$TerminalReaderInterceptor.aroundReadFrom(ReaderInterceptorExecutor.java:235)
          at org.glassfish.jersey.message.internal.ReaderInterceptorExecutor.proceed(ReaderInterceptorExecutor.java:155)
          at org.glassfish.jersey.message.internal.MessageBodyFactory.readFrom(MessageBodyFactory.java:1085)
          at org.glassfish.jersey.message.internal.InboundMessageContext.readEntity(InboundMessageContext.java:874)
          at com.mirth.connect.client.core.MirthClientResponse.readEntity(MirthClientResponse.java:40)
          at org.glassfish.jersey.message.internal.InboundMessageContext.readEntity(InboundMessageContext.java:834)
          at org.glassfish.jersey.client.ClientResponse.readEntity(ClientResponse.java:368)
          at org.glassfish.jersey.client.JerseyInvocation.translate(JerseyInvocation.java:867)
          at org.glassfish.jersey.client.JerseyInvocation.access$800(JerseyInvocation.java:92)
          at org.glassfish.jersey.client.JerseyInvocation$3.call(JerseyInvocation.java:722)
          at org.glassfish.jersey.internal.Errors.process(Errors.java:315)
          at org.glassfish.jersey.internal.Errors.process(Errors.java:297)
          at org.glassfish.jersey.internal.Errors.process(Errors.java:228)
          at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:444)
          at org.glassfish.jersey.client.JerseyInvocation.invoke(JerseyInvocation.java:718)
          at org.glassfish.jersey.client.JerseyInvocation$Builder.method(JerseyInvocation.java:459)
          at org.glassfish.jersey.client.proxy.WebResourceFactory.invoke(WebResourceFactory.java:379)
          at com.sun.proxy.$Proxy55.getChannelSummary(Unknown Source)
          at sun.reflect.GeneratedMethodAccessor62.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at com.mirth.connect.client.core.Client$2.invoke(Client.java:265)
          ... 63 more
          Caused by: com.thoughtworks.xstream.converters.ConversionException: null : null
          ---- Debugging information ----
          cause-exception     : java.lang.NullPointerException
          cause-message       : null
          class               : com.mirth.connect.model.Channel
          required-type       : com.mirth.connect.model.Transformer
          converter-type      : com.mirth.connect.model.converters.ChannelConverter
          path                : /list/channelSummary/channelStatus/channel/sourceConnector/transformer/steps
          class[1]            : com.mirth.connect.model.ChannelStatus
          converter-type[1]   : com.thoughtworks.xstream.converters.reflection.ReflectionConverter
          class[2]            : com.mirth.connect.model.ChannelSummary
          class[3]            : java.util.ArrayList
          converter-type[2]   : com.thoughtworks.xstream.converters.collections.CollectionConverter
          version             : not available
          -------------------------------
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:79)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
          at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.unmarshallField(AbstractReflectionConverter.java:474)
          at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.doUnmarshal(AbstractReflectionConverter.java:406)
          at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.unmarshal(AbstractReflectionConverter.java:257)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
          at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.unmarshallField(AbstractReflectionConverter.java:474)
          at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.doUnmarshal(AbstractReflectionConverter.java:406)
          at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.unmarshal(AbstractReflectionConverter.java:257)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
          at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
          at com.thoughtworks.xstream.converters.collections.CollectionConverter.addCurrentElementToCollection(CollectionConverter.java:98)
          at com.thoughtworks.xstream.converters.collections.CollectionConverter.populateCollection(CollectionConverter.java:91)
          at com.thoughtworks.xstream.converters.collections.CollectionConverter.populateCollection(CollectionConverter.java:85)
          at com.thoughtworks.xstream.converters.collections.CollectionConverter.unmarshal(CollectionConverter.java:80)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:65)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:50)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:134)
          at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:32)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1185)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:1157)
          at com.mirth.connect.model.converters.ObjectXMLSerializer.deserializeList(ObjectXMLSerializer.java:354)
          ... 87 more
          Caused by: java.lang.NullPointerException
          at com.thoughtworks.xstream.io.xml.DomReader.reassignCurrentElement(DomReader.java:120)
          at com.thoughtworks.xstream.io.xml.AbstractDocumentReader.moveUp(AbstractDocumentReader.java:70)
          at com.thoughtworks.xstream.io.ReaderWrapper.moveUp(ReaderWrapper.java:40)
          at com.thoughtworks.xstream.io.path.PathTrackingReader.moveUp(PathTrackingReader.java:42)
          at com.mirth.connect.model.InvalidChannel.<init>(InvalidChannel.java:27)
          at com.mirth.connect.model.converters.ChannelConverter.unmarshal(ChannelConverter.java:83)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:72)
          ... 116 more
          Davy Vandamme added a comment -

          Issue occurs also when importing channels from version 3.2.2.


            People

            • Assignee:
              Unassigned
              Reporter:
              Nick Rupley
              Assigned QA:
              Minh Tran
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development