Mirth Connect
  1. Mirth Connect
  2. MIRTH-4380

Administrator Launcher does not work if we define a http context path

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: AL 1.0.0
    • Fix Version/s: AL 1.1.0
    • Component/s: Administrator Launcher
    • Labels:
      None

      Description

      https://github.com/nextgenhealthcare/connect/issues/5

      If the variable http.contextpath (in mirth.properties) is defined other than root, the administrator launcher fails to connect with the error "Unable to retrieve payload from HTTP request. URI: https://10.33.25.176:9443/webstart".

      As can be seen in this message, the context does not appear. So it seems that one step of the connection attempt removes it.

        Activity

        Andre Felder added a comment -

        We have this same issue, we define a context path and when we launch the jnlp via the admin laucher it does not take in consideration the context path and we get a HTTP 404 page not found. Our context path we have set is /mirth. Full error is below.

        Unable to retrieve payload from HTTP request. URI: https://localhost:443/webstart/extensions/scriptfilestep.jnlp
        java.lang.Exception: Unable to retrieve payload from HTTP request. URI: https://localhost:443/webstart/extensions/scriptfilestep.jnlp
            at com.mirth.connect.client.launcher.f.a(SourceFile:782)
            at com.mirth.connect.client.launcher.f.a(SourceFile:662)
            at com.mirth.connect.client.launcher.f.a(SourceFile:307)
            at com.mirth.connect.client.launcher.MirthClientLauncher.run(SourceFile:1122)
            at java.lang.Thread.run(Thread.java:748)
        Caused by: java.lang.Exception: HTTP request returned invalid response. HTTP status: HTTP/1.1 404 Not Found, URI: https://localhost:443/webstart/extensions/scriptfilestep.jnlp
            at com.mirth.connect.client.launcher.f.a(SourceFile:771)
            ... 4 more 
        

          People

          • Assignee:
            Unassigned
            Reporter:
            Nick Rupley
          • Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: